Lines Matching refs:to

10 # Unless required by applicable law or agreed to in writing, software
20 The @rsForEach() function can be used to invoke the root kernel of a script.
22 The other functions are used to get the characteristics of the invocation of
38 This type is used to suggest how the invoked kernel should iterate over the cells of the
48 summary: Handle to a kernel invocation context
55 rs_kernel_context to your kernel function. See @rsGetDimX() and @rsGetArray0() for examples.
77 This structure is used to provide iteration information to a rsForEach call.
78 It is currently used to restrict processing to a subset of cells. In future
79 versions, it will also be used to provide hint on how to best iterate over
82 The Start fields are inclusive and the End fields are exclusive. E.g. to iterate
83 over cells 4, 5, 6, and 7 in the X dimension, set xStart to 4 and xEnd to 8.
89 summary: Handle to a kernel function
92 of this type can be used in a @rsForEach call to launch a kernel.
98 arg: rs_script script, "Script to call."
99 arg: rs_allocation input, "Allocation to source data from."
100 arg: rs_allocation output, "Allocation to write date into."
101 arg: const void* usrData, "User defined data to pass to the script. May be NULL."
102 arg: const rs_script_call_t* sc, "Extra control information used to select a sub-region of the allocation to be processed or suggest a walking strategy. May be NULL."
110 This is a synchronous function. A call to this function only returns after all
113 to the output allocation.
115 Up to API level 23, the kernel is implicitly specified as the kernel named
151 arg: size_t usrDataLen, "Size of the userData structure. This will be used to perform a shallow copy of the data if necessary."
182 arg: rs_kernel kernel, "Function designator to a function that is defined with the kernel attribute."
193 arg: rs_kernel kernel, "Function designator to a function that is defined with the kernel attribute."
198 Launches kernel in a way similar to @rsForEach. However, instead of processing
228 Internal API to launch a kernel.
245 type rs_kernel_context to your kernel function. E.g.<br/>
249 &nbsp;&nbsp;// to the other dimensions, extract them from the kernel context:<br/>
308 #TODO Add an hyperlink to something that explains Array0/1/2/3
394 type rs_kernel_context to your kernel function. E.g.<br/>