GLES20.spec revision 50d0b14689b0ae95ea7b66a8c2f7b955115812dd
1void glActiveTexture ( GLenum texture )
2void glAttachShader ( GLuint program, GLuint shader )
3void glBindAttribLocation ( GLuint program, GLuint index, const char *name )
4void glBindBuffer ( GLenum target, GLuint buffer )
5void glBindFramebuffer ( GLenum target, GLuint framebuffer )
6void glBindRenderbuffer ( GLenum target, GLuint renderbuffer )
7void glBindTexture ( GLenum target, GLuint texture )
8void glBlendColor ( GLclampf red, GLclampf green, GLclampf blue, GLclampf alpha )
9void glBlendEquation ( GLenum mode )
10void glBlendEquationSeparate ( GLenum modeRGB, GLenum modeAlpha )
11void glBlendFunc ( GLenum sfactor, GLenum dfactor )
12void glBlendFuncSeparate ( GLenum srcRGB, GLenum dstRGB, GLenum srcAlpha, GLenum dstAlpha )
13void glBufferData ( GLenum target, GLsizeiptr size, const GLvoid *data, GLenum usage )
14void glBufferSubData ( GLenum target, GLintptr offset, GLsizeiptr size, const GLvoid *data )
15GLenum glCheckFramebufferStatus ( GLenum target )
16void glClear ( GLbitfield mask )
17void glClearColor ( GLclampf red, GLclampf green, GLclampf blue, GLclampf alpha )
18void glClearDepthf ( GLclampf depth )
19void glClearStencil ( GLint s )
20void glColorMask ( GLboolean red, GLboolean green, GLboolean blue, GLboolean alpha )
21void glCompileShader ( GLuint shader )
22void glCompressedTexImage2D ( GLenum target, GLint level, GLenum internalformat, GLsizei width, GLsizei height, GLint border, GLsizei imageSize, const GLvoid *data )
23void glCompressedTexSubImage2D ( GLenum target, GLint level, GLint xoffset, GLint yoffset, GLsizei width, GLsizei height, GLenum format, GLsizei imageSize, const GLvoid *data )
24void glCopyTexImage2D ( GLenum target, GLint level, GLenum internalformat, GLint x, GLint y, GLsizei width, GLsizei height, GLint border )
25void glCopyTexSubImage2D ( GLenum target, GLint level, GLint xoffset, GLint yoffset, GLint x, GLint y, GLsizei width, GLsizei height )
26GLuint glCreateProgram ( void )
27GLuint glCreateShader ( GLenum type )
28void glCullFace ( GLenum mode )
29void glDeleteBuffers ( GLsizei n, const GLuint *buffers )
30void glDeleteFramebuffers ( GLsizei n, const GLuint *framebuffers )
31void glDeleteProgram ( GLuint program )
32void glDeleteRenderbuffers ( GLsizei n, const GLuint *renderbuffers )
33void glDeleteShader ( GLuint shader )
34void glDeleteTextures ( GLsizei n, const GLuint *textures )
35void glDepthFunc ( GLenum func )
36void glDepthMask ( GLboolean flag )
37void glDepthRangef ( GLclampf zNear, GLclampf zFar )
38void glDetachShader ( GLuint program, GLuint shader )
39void glDisable ( GLenum cap )
40void glDisableVertexAttribArray ( GLuint index )
41void glDrawArrays ( GLenum mode, GLint first, GLsizei count )
42void glDrawElements ( GLenum mode, GLsizei count, GLenum type, const GLvoid *indices )
43void glEnable ( GLenum cap )
44void glEnableVertexAttribArray ( GLuint index )
45void glFinish ( void )
46void glFlush ( void )
47void glFramebufferRenderbuffer ( GLenum target, GLenum attachment, GLenum renderbuffertarget, GLuint renderbuffer )
48void glFramebufferTexture2D ( GLenum target, GLenum attachment, GLenum textarget, GLuint texture, GLint level )
49void glFrontFace ( GLenum mode )
50void glGenBuffers ( GLsizei n, GLuint *buffers )
51void glGenerateMipmap ( GLenum target )
52void glGenFramebuffers ( GLsizei n, GLuint *framebuffers )
53void glGenRenderbuffers ( GLsizei n, GLuint *renderbuffers )
54void glGenTextures ( GLsizei n, GLuint *textures )
55void glGetActiveAttrib ( GLuint program, GLuint index, GLsizei bufsize, GLsizei *length, GLint *size, GLenum *type, char *name )
56void glGetActiveUniform ( GLuint program, GLuint index, GLsizei bufsize, GLsizei *length, GLint *size, GLenum *type, char *name )
57void glGetAttachedShaders ( GLuint program, GLsizei maxcount, GLsizei *count, GLuint *shaders )
58int glGetAttribLocation ( GLuint program, const char *name )
59void glGetBooleanv ( GLenum pname, GLboolean *params )
60void glGetBufferParameteriv ( GLenum target, GLenum pname, GLint *params )
61GLenum glGetError ( void )
62void glGetFloatv ( GLenum pname, GLfloat *params )
63void glGetFramebufferAttachmentParameteriv ( GLenum target, GLenum attachment, GLenum pname, GLint *params )
64void glGetIntegerv ( GLenum pname, GLint *params )
65void glGetProgramiv ( GLuint program, GLenum pname, GLint *params )
66void glGetProgramInfoLog ( GLuint program, GLsizei bufsize, GLsizei *length, char *infolog )
67void glGetRenderbufferParameteriv ( GLenum target, GLenum pname, GLint *params )
68void glGetShaderiv ( GLuint shader, GLenum pname, GLint *params )
69void glGetShaderInfoLog ( GLuint shader, GLsizei bufsize, GLsizei *length, char *infolog )
70void glGetShaderPrecisionFormat ( GLenum shadertype, GLenum precisiontype, GLint *range, GLint *precision )
71void glGetShaderSource ( GLuint shader, GLsizei bufsize, GLsizei *length, char *source )
72const GLubyte * glGetString ( GLenum name )
73void glGetTexParameterfv ( GLenum target, GLenum pname, GLfloat *params )
74void glGetTexParameteriv ( GLenum target, GLenum pname, GLint *params )
75void glGetUniformfv ( GLuint program, GLint location, GLfloat *params )
76void glGetUniformiv ( GLuint program, GLint location, GLint *params )
77int glGetUniformLocation ( GLuint program, const char *name )
78void glGetVertexAttribfv ( GLuint index, GLenum pname, GLfloat *params )
79void glGetVertexAttribiv ( GLuint index, GLenum pname, GLint *params )
80// void glGetVertexAttribPointerv ( GLuint index, GLenum pname, void **pointer )
81void glHint ( GLenum target, GLenum mode )
82GLboolean glIsBuffer ( GLuint buffer )
83GLboolean glIsEnabled ( GLenum cap )
84GLboolean glIsFramebuffer ( GLuint framebuffer )
85GLboolean glIsProgram ( GLuint program )
86GLboolean glIsRenderbuffer ( GLuint renderbuffer )
87GLboolean glIsShader ( GLuint shader )
88GLboolean glIsTexture ( GLuint texture )
89void glLineWidth ( GLfloat width )
90void glLinkProgram ( GLuint program )
91void glPixelStorei ( GLenum pname, GLint param )
92void glPolygonOffset ( GLfloat factor, GLfloat units )
93void glReadPixels ( GLint x, GLint y, GLsizei width, GLsizei height, GLenum format, GLenum type, GLvoid *pixels )
94void glReleaseShaderCompiler ( void )
95void glRenderbufferStorage ( GLenum target, GLenum internalformat, GLsizei width, GLsizei height )
96void glSampleCoverage ( GLclampf value, GLboolean invert )
97void glScissor ( GLint x, GLint y, GLsizei width, GLsizei height )
98void glShaderBinary ( GLsizei n, const GLuint *shaders, GLenum binaryformat, const GLvoid *binary, GLsizei length )
99void glShaderSource ( GLuint shader )
100void glStencilFunc ( GLenum func, GLint ref, GLuint mask )
101void glStencilFuncSeparate ( GLenum face, GLenum func, GLint ref, GLuint mask )
102void glStencilMask ( GLuint mask )
103void glStencilMaskSeparate ( GLenum face, GLuint mask )
104void glStencilOp ( GLenum fail, GLenum zfail, GLenum zpass )
105void glStencilOpSeparate ( GLenum face, GLenum fail, GLenum zfail, GLenum zpass )
106void glTexImage2D ( GLenum target, GLint level, GLint internalformat, GLsizei width, GLsizei height, GLint border, GLenum format, GLenum type, const GLvoid *pixels )
107void glTexParameterf ( GLenum target, GLenum pname, GLfloat param )
108void glTexParameterfv ( GLenum target, GLenum pname, const GLfloat *params )
109void glTexParameteri ( GLenum target, GLenum pname, GLint param )
110void glTexParameteriv ( GLenum target, GLenum pname, const GLint *params )
111void glTexSubImage2D ( GLenum target, GLint level, GLint xoffset, GLint yoffset, GLsizei width, GLsizei height, GLenum format, GLenum type, const GLvoid *pixels )
112void glUniform1f ( GLint location, GLfloat x )
113void glUniform1fv ( GLint location, GLsizei count, const GLfloat *v )
114void glUniform1i ( GLint location, GLint x )
115void glUniform1iv ( GLint location, GLsizei count, const GLint *v )
116void glUniform2f ( GLint location, GLfloat x, GLfloat y )
117void glUniform2fv ( GLint location, GLsizei count, const GLfloat *v )
118void glUniform2i ( GLint location, GLint x, GLint y )
119void glUniform2iv ( GLint location, GLsizei count, const GLint *v )
120void glUniform3f ( GLint location, GLfloat x, GLfloat y, GLfloat z )
121void glUniform3fv ( GLint location, GLsizei count, const GLfloat *v )
122void glUniform3i ( GLint location, GLint x, GLint y, GLint z )
123void glUniform3iv ( GLint location, GLsizei count, const GLint *v )
124void glUniform4f ( GLint location, GLfloat x, GLfloat y, GLfloat z, GLfloat w )
125void glUniform4fv ( GLint location, GLsizei count, const GLfloat *v )
126void glUniform4i ( GLint location, GLint x, GLint y, GLint z, GLint w )
127void glUniform4iv ( GLint location, GLsizei count, const GLint *v )
128void glUniformMatrix2fv ( GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
129void glUniformMatrix3fv ( GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
130void glUniformMatrix4fv ( GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
131void glUseProgram ( GLuint program )
132void glValidateProgram ( GLuint program )
133void glVertexAttrib1f ( GLuint indx, GLfloat x )
134void glVertexAttrib1fv ( GLuint indx, const GLfloat *values )
135void glVertexAttrib2f ( GLuint indx, GLfloat x, GLfloat y )
136void glVertexAttrib2fv ( GLuint indx, const GLfloat *values )
137void glVertexAttrib3f ( GLuint indx, GLfloat x, GLfloat y, GLfloat z )
138void glVertexAttrib3fv ( GLuint indx, const GLfloat *values )
139void glVertexAttrib4f ( GLuint indx, GLfloat x, GLfloat y, GLfloat z, GLfloat w )
140void glVertexAttrib4fv ( GLuint indx, const GLfloat *values )
141void glVertexAttribPointer ( GLuint indx, GLint size, GLenum type, GLboolean normalized, GLsizei stride, const GLvoid *ptr )
142void glViewport ( GLint x, GLint y, GLsizei width, GLsizei height )