p9.cpp revision cb8845f3e358b8583c41ba9bdb9165670900a8e2
1// RUN: clang-cc -verify %s
2
3struct S; // expected-note {{forward declaration of 'struct S'}}
4extern S a;
5extern S f();
6extern void g(S a); // expected-note {{candidate function}}
7
8void h() {
9  // FIXME: This diagnostic could be better.
10  g(a); // expected-error {{no matching function for call to 'g'}}
11  f(); // expected-error {{return type of called function ('struct S') is incomplete}}
12}
13