p2-0x.cpp revision 3e4c6c4c79a03f5cb0c4671d7c282d623c6dc35e
1// RUN: %clang_cc1 -std=c++0x -fsyntax-only -verify %s
2
3struct A { };
4template<typename T> using X = A; // expected-note {{declared here}}
5struct X<int>* p2; // expected-error {{elaborated type refers to a type alias template}}
6
7
8template<typename T> using Id = T; // expected-note {{declared here}}
9template<template<typename> class F>
10struct Y {
11  struct F<int> i; // expected-error {{elaborated type refers to a type alias template}}
12};
13template struct Y<Id>; // expected-note {{requested here}}
14