p3-0x.cpp revision ad762fcdc16b9e4705b12b09d92b8c026212b906
1// RUN: %clang_cc1 -std=c++0x -fsyntax-only -verify %s
2
3// FIXME: when clang supports alias-declarations.
4#if 0
5using X = struct { // ok
6};
7#endif
8
9class K {
10  virtual ~K();
11  // FIXME: the diagnostic here isn't very good
12  operator struct S {} (); // expected-error 2{{}}
13};
14
15void f() {
16  int arr[3] = {1,2,3};
17
18  for (struct S { S(int) {} } s : arr) { // expected-error {{types may not be defined in a for range declaration}}
19  }
20
21  new struct T {}; // expected-error {{allocation of incomplete type}} expected-note {{forward declaration}}
22
23  // FIXME: the diagnostic here isn't very good
24  try {} catch (struct U {}); // expected-error 3{{}} expected-note 2{{}}
25
26  (void)(struct V { V(int); })0; // expected-error {{'V' can not be defined in a type specifier}}
27
28  (void)dynamic_cast<struct W {}*>((K*)0); // expected-error {{'W' can not be defined in a type specifier}}
29  (void)static_cast<struct X {}*>(0); // expected-error {{'X' can not be defined in a type specifier}}
30  (void)reinterpret_cast<struct Y {}*>(0); // expected-error {{'Y' can not be defined in a type specifier}}
31  (void)const_cast<struct Z {}*>((const Z*)0); // expected-error {{'Z' can not be defined in a type specifier}}
32}
33
34void g() throw (struct Ex {}) { // expected-error {{'Ex' can not be defined in a type specifier}}
35}
36
37// FIXME: this currently gives a strange error because alignas is not recognised as a keyword yet.
38int alignas(struct Aa {}) x; // expected-error {{'Aa' can not be defined in a parameter type}} expected-error {{expected function body}}
39
40int a = sizeof(struct So {}); // expected-error {{'So' can not be defined in a type specifier}}
41int b = alignof(struct Ao {}); // expected-error {{'Ao' can not be defined in a type specifier}}
42
43namespace std { struct type_info; }
44const std::type_info &ti = typeid(struct Ti {}); // expected-error {{'Ti' can not be defined in a type specifier}}
45