p11.cpp revision 6bcf27bb9a4b5c3f79cb44c0e4654a6d7619ad89
1// RUN: %clang_cc1 -std=c++11 -fexceptions -fcxx-exceptions -fsyntax-only -verify %s
2// expected-no-diagnostics
3
4// This is the "let the user shoot themselves in the foot" clause.
5void f() noexcept {
6  throw 0; // no-error
7}
8void g() throw() {
9  throw 0; // no-error
10}
11void h() throw(int) {
12  throw 0.0; // no-error
13}
14