p9-0x.cpp revision 762bb9d0ad20320b9f97a841dce57ba5e8e48b07
1// RUN: %clang_cc1 -std=c++11 -fsyntax-only -verify %s
2
3// -- The argument list of the specialization shall not be identical
4//    to the implicit argument list of the primary template.
5
6template<typename T, typename ...Types>
7struct X1;
8
9template<typename T, typename ...Types>
10struct X1<T, Types...> // expected-error{{class template partial specialization does not specialize any template argument; to define the primary template, remove the template argument list}}
11{ };
12
13
14