p3.cpp revision 8b29f57d867495ace41cda6a06013f05961c68ca
1// RUN: %clang_cc1 -fsyntax-only -verify %s
2
3template<class X, class Y, class Z> X f(Y,Z); // expected-note {{candidate function}}
4
5void g() {
6  f<int,char*,double>("aa",3.0);
7  f<int,char*>("aa",3.0); // Z is deduced to be double
8  f<int>("aa",3.0);       // Y is deduced to be char*, and
9                          // Z is deduced to be double
10  f("aa",3.0); // expected-error{{no matching}}
11}
12