basic.cpp revision 29805ca6d278b4d9563adfee67f2478f0fecdcfc
1// RUN: %clang_cc1 -fsyntax-only -verify %s
2
3template<typename T> struct A { };
4
5template<typename T> A<T> f0(T*);
6
7void test_f0(int *ip, float const *cfp) {
8  A<int> a0 = f0(ip);
9  A<const float> a1 = f0(cfp);
10}
11
12template<typename T> void f1(T*, int);
13
14void test_f1(int *ip, float fv) {
15  f1(ip, fv);
16}
17
18template<typename T> void f2(T*, T*); // expected-note {{candidate template ignored: could not match 'T *' against 'ConvToIntPtr'}} \
19// expected-note{{candidate template ignored: deduced conflicting types for parameter 'T' ('int' vs. 'float')}}
20
21struct ConvToIntPtr {
22  operator int*() const;
23};
24
25void test_f2(int *ip, float *fp) {
26  f2(ip, ConvToIntPtr()); // expected-error{{no matching function}}
27  f2(ip, ip); // okay
28  f2(ip, fp); // expected-error{{no matching function}}
29}
30