p9-0x.cpp revision b939a1987318f802fd25f89e15ae7d2423161cac
1// RUN: %clang_cc1 -std=c++0x -fsyntax-only -verify %s
2
3template<typename T> int &f0(T&);
4template<typename T> float &f0(T&&);
5
6// Core issue 1164
7void test_f0(int i) {
8  int &ir0 = f0(i);
9  float &fr0 = f0(5);
10}
11