p1-0x.cpp revision 762bb9d0ad20320b9f97a841dce57ba5e8e48b07
1// RUN: %clang_cc1 -fsyntax-only -std=c++11 -verify %s
2
3template<typename T>
4struct X {
5  void f() {}
6};
7
8template inline void X<int>::f(); // expected-error{{'inline'}}
9
10// FIXME: test constexpr
11