p1-0x.cpp revision fe6f64846b8714b2951d9ea80fc40a3e020f3920
1// RUN: %clang_cc1 -fsyntax-only -std=c++11 -verify %s
2
3template<typename T>
4struct X {
5  void f() {}
6};
7
8template inline void X<int>::f(); // expected-error{{explicit instantiation cannot be 'inline'}}
9
10template<typename T>
11struct Y {
12  constexpr int f() { return 0; }
13};
14
15template constexpr int Y<int>::f(); // expected-error{{explicit instantiation cannot be 'constexpr'}}
16