1define(MULTIARCH_HEADERS,ifdef(`DO_MULTIARCH',
2Multi-Arch: same
3Pre-Depends: ${misc:Pre-Depends},REMOVE_ME))dnl
4define(UTIL_LINUX_NG_DEFINES,
5ifdef(`UTIL_LINUX_NG', ``libblkid-dev (>= 2.16), uuid-dev (>= 2.16),''))dnl
6define(DIETLIBC_DEFINES,
7ifdef(`DIETLIBC', ``dietlibc-dev (>> 0.30) [alpha amd64 arm hppa i386 ia64 powerpc ppc64 s390 sparc],''))dnl
8Source: e2fsprogs
9Section: admin
10Priority: required
11Maintainer: Theodore Y. Ts'o <tytso@mit.edu>
12Build-Depends: gettext, texinfo, pkg-config, DIETLIBC_DEFINES gcc-multilib [mips mipsel], debhelper (>= 7.0), UTIL_LINUX_NG_DEFINES m4
13Standards-Version: 3.9.5
14Homepage: http://e2fsprogs.sourceforge.net
15
16ifdef(`E2FSCK_STATIC',``
17Package: e2fsck-static
18Priority: optional
19Depends: ${shlibs:Depends}, ${misc:Depends}
20Recommends: sash | bash-static | zsh-static | busybox-static | zsh30-static
21Architecture: any
22Description: statically-linked version of the ext2/ext3/ext4 filesystem checker
23 This may be of some help to you if your filesystem gets corrupted enough
24 to break the shared libraries used by the dynamically linked checker.
25 .
26 This binary takes much more space than its dynamic counterpart located
27 in e2fsprogs, though.
28 .
29 You may want to install a statically-linked shell as well, to be able
30 to run this program if something like your C library gets corrupted.
31'')dnl
32
33Package: libcomerr2
34Section: libs
35Provides: libcomerr-kth-compat
36Depends: ${shlibs:Depends}, ${misc:Depends}
37Replaces: e2fsprogs (<< 1.34-1)
38Architecture: any
39MULTIARCH_HEADERS
40Description: common error description library
41 libcomerr is an attempt to present a common error-handling mechanism to
42 manipulate the most common form of error code in a fashion that does not
43 have the problems identified with mechanisms commonly in use.
44
45Package: comerr-dev
46Section: libdevel
47Priority: extra
48Depends: libc6-dev | libc-dev, libcomerr2 (= ${mainBinary}), ${misc:Depends}
49Suggests: doc-base
50Replaces: e2fslibs-dev (<< 1.33-2), libkrb5-dev (<< 1.3)
51Architecture: any
52Description: common error description library - headers and static libraries
53 libcom_err is an attempt to present a common error-handling mechanism to
54 manipulate the most common form of error code in a fashion that does not
55 have the problems identified with mechanisms commonly in use.
56 .
57 This package contains the development environment for the com_err library.
58
59Package: libss2
60Section: libs
61Depends: libcomerr2, ${shlibs:Depends}, ${misc:Depends}
62Replaces: e2fsprogs (<< 1.34-1)
63Architecture: any
64MULTIARCH_HEADERS
65Description: command-line interface parsing library
66 libss provides a simple command-line interface parser which will
67 accept input from the user, parse the command into an argv argument
68 vector, and then dispatch it to a handler function.
69 . 
70 It was originally inspired by the Multics SubSystem library.
71
72Package: ss-dev
73Section: libdevel
74Priority: extra
75Depends: libc6-dev | libc-dev, libss2 (= ${mainBinary}), comerr-dev, ${misc:Depends}
76Architecture: any
77Description: command-line interface parsing library - headers and static libraries
78 This package includes a tool that parses a command table to generate
79 a simple command-line interface parser, the include files needed to
80 compile and use it, and the static libs.
81 . 
82 It was originally inspired by the Multics SubSystem library.
83 .
84 This package contains the development environment for the ss library.
85ifdef(`UTIL_LINUX_NG',,``
86Package: libuuid1
87Section: libs
88Depends: passwd, ${shlibs:Depends}, ${misc:Depends}
89Recommends: uuid-runtime
90Replaces: e2fsprogs (<< 1.34-1)
91Architecture: any
92MULTIARCH_HEADERS
93Description: Universally Unique ID library
94 The libuuid library generates and parses 128-bit universally unique
95 ids (UUIDs).  A UUID is an identifier that is unique across both
96 space and time, with respect to the space of all UUIDs.  A UUID can
97 be used for multiple purposes, from tagging objects with an extremely
98 short lifetime, to reliably identifying very persistent objects
99 across a network.
100 .
101 See RFC 4122 for more information.  
102
103Package: uuid-runtime
104Section: libs
105Priority: optional
106Depends: passwd, libuuid1 (>> 1.40.3-1), ${shlibs:Depends}, ${misc:Depends}
107Replaces: e2fsprogs (<= 1.40.3-1ubuntu1)
108Architecture: any
109Description: runtime components for the Universally Unique ID library
110 The libuuid library generates and parses 128-bit universally unique
111 ids (UUIDs).  A UUID is an identifier that is unique across both
112 space and time, with respect to the space of all UUIDs.  A UUID can
113 be used for multiple purposes, from tagging objects with an extremely
114 short lifetime, to reliably identifying very persistent objects
115 across a network.
116 .
117 See RFC 4122 for more information.  
118 .
119 This package contains the uuidgen program and the uuidd daemon.
120 .
121 The uuidd daemon is used to generate UUIDs, especially time-based
122 UUID’s, in a secure and guaranteed-unique fashion, even in the face
123 of large numbers of threads trying to grab UUID’s running on
124 different CPU’s. It is used by libuuid as well as the uuidgen
125 program.
126
127Package: libuuid1-udeb
128XC-Package-Type: udeb
129Section: debian-installer
130Priority: optional
131Depends: ${shlibs:Depends}
132Architecture: any
133Description: stripped down universally unique id library, for debian-installer
134 libuuid generates and parses 128-bit universally unique ids (UUIDs).
135 See RFC 4122 for more information.
136 .
137 This is a minimal package for debian-installer.
138
139Package: uuid-dev
140Section: libdevel
141Priority: extra
142Depends: libc6-dev | libc-dev, libuuid1 (= ${mainBinary}), ${misc:Depends}
143Replaces: e2fslibs-dev (<< 1.15)
144Architecture: any
145Description: universally unique id library - headers and static libraries
146 libuuid generates and parses 128-bit universally unique ids (UUIDs).
147 See RFC 4122 for more information.
148 .
149 This package contains the development environment for the uuid library.
150
151Package: libblkid1
152Section: libs
153Depends: ${shlibs:Depends}, ${misc:Depends}
154Architecture: any
155Description: block device id library
156 The blkid library which allows system programs like fsck and 
157 mount to quickly and easily find block devices by filesystem UUID and 
158 LABEL.  This allows system administrators to avoid specifying 
159 filesystems by hard-coded device names, but via a logical naming 
160 system instead.
161
162Package: libblkid1-udeb
163XC-Package-Type: udeb
164Section: debian-installer
165Priority: optional
166Depends: ${shlibs:Depends}, ${misc:Depends}
167Architecture: any
168Description: stripped down block device id library, for debian-installer
169 The blkid library which allows system programs like fsck and 
170 mount to quickly and easily find block devices by filesystem UUID and 
171 LABEL.  This allows system administrators to avoid specifiying 
172 filesystems by hard-coded device names, but via a logical naming 
173 system instead.
174 .
175 This is a minimal package for debian-installer.
176
177Package: libblkid-dev
178Section: libdevel
179Priority: extra
180Depends: libc6-dev | libc-dev, libblkid1 (= ${binary:Version}), ${misc:Depends}
181Architecture: any
182Description: block device id library - headers and static libraries
183 The blkid library which allows system programs like fsck and 
184 mount to quickly and easily find block devices by filesystem UUID and 
185 LABEL.  This allows system administrators to avoid specifiying 
186 filesystems by hard-coded device names, but via a logical naming 
187 system instead.
188 .
189 This package contains the development environment for the blkid library.
190'')dnl
191
192Package: e2fsprogs-udeb
193XC-Package-Type: udeb
194Section: debian-installer
195Priority: optional
196Depends: ${shlibs:Depends}, ${misc:Depends}
197Architecture: any
198Description: stripped-down versions of e2fsprogs, for debian-installer
199 This package is an e2fsprogs package built for a reduced size, so that
200 it can help to save space in debian-installer.
201 .
202 Don't attempt to install this package, it has no support for a couple of
203 features you surely want.  Anyway it should refuse to install.
204
205Package: e2fslibs
206Section: libs
207Depends: ${shlibs:Depends}, ${misc:Depends}
208Replaces: e2fsprogs (<< 1.34-1)
209Provides: libext2fs2, libe2p2
210Architecture: any
211MULTIARCH_HEADERS
212Description: ext2/ext3/ext4 file system libraries
213 The ext2, ext3 and ext4 file systems are successors of the original ext
214 ("extended") file system. They are the main file system types used for
215 hard disks on Debian and other Linux systems.
216 .
217 This package provides the ext2fs and e2p libraries, for userspace software
218 that directly accesses extended file systems. Programs that use libext2fs
219 include e2fsck, mke2fs, and tune2fs. Programs that use libe2p include
220 dumpe2fs, chattr, and lsattr.
221
222Package: e2fslibs-dev
223Section: libdevel
224Priority: extra
225Depends: libc6-dev | libc-dev, comerr-dev, e2fslibs (= ${binary:Version}), ${misc:Depends}
226Suggests: doc-base
227Provides: ext2fs-dev, e2p-dev
228Replaces: libkrb5-dev (<< 1.3)
229Architecture: any
230Description: ext2/ext3/ext4 file system libraries - headers and static libraries
231 The ext2, ext3 and ext4 file systems are successors of the original ext
232 ("extended") file system. They are the main file system types used for
233 hard disks on Debian and other Linux systems.
234 .
235 This package contains the development environment for the ext2fs and e2p 
236 libraries.
237
238Package: e2fsprogs
239Essential: yes
240ifdef(`UTIL_LINUX_NG',
241``Pre-Depends: ${shlibs:Depends}, ${misc:Depends}, util-linux (>= 2.15~rc1-1)
242'',
243``Pre-Depends: ${shlibs:Depends}, ${misc:Depends}
244'')dnl
245Multi-Arch: foreign
246Suggests: gpart, parted, e2fsck-static
247Conflicts: dump (<< 0.4b4-4), quota (<< 1.55-8.1), initscripts (<< 2.85-4), sysvinit (<< 2.85-4)
248Replaces: hurd (<= 20040301-1), libblkid1 (<< 1.38+1.39-WIP-2005.12.10-2), libuuid1 (<< 1.38+1.39-WIP-2005.12.10-2)
249Architecture: any
250Description: ext2/ext3/ext4 file system utilities
251 The ext2, ext3 and ext4 file systems are successors of the original ext
252 ("extended") file system. They are the main file system types used for
253 hard disks on Debian and other Linux systems.
254 .
255 This package contains programs for creating, checking, and maintaining
256 ext2/3/4-based file systems.
257
258Package: e2fsprogs-dbg
259Section: debug
260Priority: extra
261Depends: e2fsprogs (= ${binary:Version}), ${misc:Depends}
262Architecture: any
263Description: debugging information for e2fsprogs
264 This package includes the debug information useful for debugging e2fsprogs
265 and its libraries, contained in the e2fsprogs and e2fsck-static packages.
266 The debug information is used for execution tracing and core
267 dump analysis. 
268ifdef(`UTIL_LINUX_NG',,``
269Package: uuid-runtime-dbg
270Section: debug
271Priority: extra
272Depends: uuid-runtime (= ${binary:Version}), ${misc:Depends}
273Architecture: any
274Description: debugging information for uuid-runtime
275 This package includes the debug information useful for debugging the
276 uuid runtime programs, contained in the uuid-runtime package.
277 The debugging information is used for execution tracing and core
278 dump analysis.
279'')dnl
280
281Package: e2fslibs-dbg
282Section: debug
283Priority: extra
284Depends: e2fslibs (= ${binary:Version}), ${misc:Depends}
285Architecture: any
286Description: debugging information for e2fslibs
287 This package includes the debug information useful for debugging the
288 ext2fs and e2p libraries, contained in the e2fslibs package.  The debug
289 information is used for execution tracing and core dump analysis.
290
291Package: libcomerr2-dbg
292Section: debug
293Priority: extra
294Depends: libcomerr2 (= ${binary:Version}), ${misc:Depends}
295Architecture: any
296Description: debugging information for libcomerr2
297 This package includes the debug information useful for debugging the
298 com_err library, contained in the libcomerr2 package.  The debugging
299 information is used for execution tracing and core dump analysis.
300
301Package: libss2-dbg
302Section: debug
303Priority: extra
304Depends: libss2 (= ${binary:Version}), ${misc:Depends}
305Architecture: any
306Description: debugging information for libss2
307 This package includes the debug information useful for debugging the
308 ss library, contained in the libss2 package.  The debug information
309 is used for execution tracing and core dump analysis.
310ifdef(`UTIL_LINUX_NG',,``
311Package: libblkid1-dbg
312Section: debug
313Priority: extra
314Depends: libblkid1 (= ${binary:Version}), ${misc:Depends}
315Architecture: any
316Description: debugging information for libblkid1
317 This package includes the debug information useful for debugging the
318 blkid library, contained in the libblkid1 package.  The debug
319 information is used for execution tracing and core dump analysis.
320
321Package: libuuid1-dbg
322Section: debug
323Priority: extra
324Depends: libuuid1 (= ${binary:Version}), ${misc:Depends}
325Architecture: any
326Description: debugging information for libuuid1
327 This package includes the debug information useful for debugging the
328 UUID library, contained in the libuuid1 package.  The debug
329 information is used for execution tracing and core dump analysis.
330'')dnl
331