control.in revision d2051f11044290d288a4f03220f07fe9651588c9
1define(MULTIARCH_HEADERS,ifdef(`DO_MULTIARCH',
2Multi-Arch: same
3Pre-Depends: ${misc:Pre-Depends},REMOVE_ME))dnl
4define(UTIL_LINUX_NG_DEFINES,
5ifdef(`UTIL_LINUX_NG', ``libblkid-dev (>= 2.16), uuid-dev (>= 2.16),''))dnl
6define(DIETLIBC_DEFINES,
7ifdef(`DIETLIBC', ``dietlibc-dev (>> 0.30) [alpha amd64 arm hppa i386 ia64 powerpc ppc64 s390 sparc],''))dnl
8Source: e2fsprogs
9Section: admin
10Priority: required
11Maintainer: Theodore Y. Ts'o <tytso@mit.edu>
12Build-Depends: texi2html (>= 1.76), gettext, texinfo, dc, pkg-config, DIETLIBC_DEFINES gcc-multilib [mips mipsel], debhelper (>= 7.0), UTIL_LINUX_NG_DEFINES m4
13Standards-Version: 3.9.3
14Homepage: http://e2fsprogs.sourceforge.net
15
16Package: e2fsck-static
17Priority: optional
18Depends: ${shlibs:Depends}, ${misc:Depends}
19Recommends: sash | bash-static | zsh-static | busybox-static | zsh30-static
20Architecture: any
21Description: statically-linked version of the ext2/ext3/ext4 filesystem checker
22 This may be of some help to you if your filesystem gets corrupted enough
23 to break the shared libraries used by the dynamically linked checker.
24 .
25 This binary takes much more space than its dynamic counterpart located
26 in e2fsprogs, though.
27 .
28 You may want to install a statically-linked shell as well, to be able
29 to run this program if something like your C library gets corrupted.
30
31Package: libcomerr2
32Section: libs
33Provides: libcomerr-kth-compat
34Depends: ${shlibs:Depends}, ${misc:Depends}
35Replaces: e2fsprogs (<< 1.34-1)
36Architecture: any
37MULTIARCH_HEADERS
38Description: common error description library
39 libcomerr is an attempt to present a common error-handling mechanism to
40 manipulate the most common form of error code in a fashion that does not
41 have the problems identified with mechanisms commonly in use.
42
43Package: comerr-dev
44Section: libdevel
45Priority: extra
46Depends: libc6-dev | libc-dev, libcomerr2 (= ${mainBinary}), ${misc:Depends}
47Suggests: doc-base
48Replaces: e2fslibs-dev (<< 1.33-2), libkrb5-dev (<< 1.3)
49Architecture: any
50Description: common error description library - headers and static libraries
51 libcom_err is an attempt to present a common error-handling mechanism to
52 manipulate the most common form of error code in a fashion that does not
53 have the problems identified with mechanisms commonly in use.
54 .
55 This package contains the development environment for the com_err library.
56
57Package: libss2
58Section: libs
59Depends: libcomerr2, ${shlibs:Depends}, ${misc:Depends}
60Replaces: e2fsprogs (<< 1.34-1)
61Architecture: any
62MULTIARCH_HEADERS
63Description: command-line interface parsing library
64 libss provides a simple command-line interface parser which will
65 accept input from the user, parse the command into an argv argument
66 vector, and then dispatch it to a handler function.
67 . 
68 It was originally inspired by the Multics SubSystem library.
69
70Package: ss-dev
71Section: libdevel
72Priority: extra
73Depends: libc6-dev | libc-dev, libss2 (= ${mainBinary}), comerr-dev, ${misc:Depends}
74Architecture: any
75Description: command-line interface parsing library - headers and static libraries
76 This package includes a tool that parses a command table to generate
77 a simple command-line interface parser, the include files needed to
78 compile and use it, and the static libs.
79 . 
80 It was originally inspired by the Multics SubSystem library.
81 .
82 This package contains the development environment for the ss library.
83ifdef(`UTIL_LINUX_NG',,``
84Package: libuuid1
85Section: libs
86Depends: passwd, ${shlibs:Depends}, ${misc:Depends}
87Recommends: uuid-runtime
88Replaces: e2fsprogs (<< 1.34-1)
89Architecture: any
90MULTIARCH_HEADERS
91Description: Universally Unique ID library
92 The libuuid library generates and parses 128-bit universally unique
93 ids (UUIDs).  A UUID is an identifier that is unique across both
94 space and time, with respect to the space of all UUIDs.  A UUID can
95 be used for multiple purposes, from tagging objects with an extremely
96 short lifetime, to reliably identifying very persistent objects
97 across a network.
98 .
99 See RFC 4122 for more information.  
100
101Package: uuid-runtime
102Section: libs
103Priority: optional
104Depends: passwd, libuuid1 (>> 1.40.3-1), ${shlibs:Depends}, ${misc:Depends}
105Replaces: e2fsprogs (<= 1.40.3-1ubuntu1)
106Architecture: any
107Description: runtime components for the Universally Unique ID library
108 The libuuid library generates and parses 128-bit universally unique
109 ids (UUIDs).  A UUID is an identifier that is unique across both
110 space and time, with respect to the space of all UUIDs.  A UUID can
111 be used for multiple purposes, from tagging objects with an extremely
112 short lifetime, to reliably identifying very persistent objects
113 across a network.
114 .
115 See RFC 4122 for more information.  
116 .
117 This package contains the uuidgen program and the uuidd daemon.
118 .
119 The uuidd daemon is used to generate UUIDs, especially time-based
120 UUID’s, in a secure and guaranteed-unique fashion, even in the face
121 of large numbers of threads trying to grab UUID’s running on
122 different CPU’s. It is used by libuuid as well as the uuidgen
123 program.
124
125Package: libuuid1-udeb
126XC-Package-Type: udeb
127Section: debian-installer
128Priority: optional
129Depends: ${shlibs:Depends}
130Architecture: any
131Description: stripped down universally unique id library, for debian-installer
132 libuuid generates and parses 128-bit universally unique ids (UUIDs).
133 See RFC 4122 for more information.
134 .
135 This is a minimal package for debian-installer.
136
137Package: uuid-dev
138Section: libdevel
139Priority: extra
140Depends: libc6-dev | libc-dev, libuuid1 (= ${mainBinary}), ${misc:Depends}
141Replaces: e2fslibs-dev (<< 1.15)
142Architecture: any
143Description: universally unique id library - headers and static libraries
144 libuuid generates and parses 128-bit universally unique ids (UUIDs).
145 See RFC 4122 for more information.
146 .
147 This package contains the development environment for the uuid library.
148
149Package: libblkid1
150Section: libs
151Depends: ${shlibs:Depends}, ${misc:Depends}
152Architecture: any
153Description: block device id library
154 The blkid library which allows system programs like fsck and 
155 mount to quickly and easily find block devices by filesystem UUID and 
156 LABEL.  This allows system administrators to avoid specifying 
157 filesystems by hard-coded device names, but via a logical naming 
158 system instead.
159
160Package: libblkid1-udeb
161XC-Package-Type: udeb
162Section: debian-installer
163Priority: optional
164Depends: ${shlibs:Depends}, ${misc:Depends}
165Architecture: any
166Description: stripped down block device id library, for debian-installer
167 The blkid library which allows system programs like fsck and 
168 mount to quickly and easily find block devices by filesystem UUID and 
169 LABEL.  This allows system administrators to avoid specifiying 
170 filesystems by hard-coded device names, but via a logical naming 
171 system instead.
172 .
173 This is a minimal package for debian-installer.
174
175Package: libblkid-dev
176Section: libdevel
177Priority: extra
178Depends: libc6-dev | libc-dev, libblkid1 (= ${binary:Version}), ${misc:Depends}
179Architecture: any
180Description: block device id library - headers and static libraries
181 The blkid library which allows system programs like fsck and 
182 mount to quickly and easily find block devices by filesystem UUID and 
183 LABEL.  This allows system administrators to avoid specifiying 
184 filesystems by hard-coded device names, but via a logical naming 
185 system instead.
186 .
187 This package contains the development environment for the blkid library.
188'')dnl
189
190Package: e2fsprogs-udeb
191XC-Package-Type: udeb
192Section: debian-installer
193Priority: optional
194Depends: ${shlibs:Depends}, ${misc:Depends}
195Architecture: any
196Description: stripped-down versions of e2fsprogs, for debian-installer
197 This package is an e2fsprogs package built for a reduced size, so that
198 it can help to save space in debian-installer.
199 .
200 Don't attempt to install this package, it has no support for a couple of
201 features you surely want.  Anyway it should refuse to install.
202
203Package: e2fslibs
204Section: libs
205Depends: ${shlibs:Depends}, ${misc:Depends}
206Replaces: e2fsprogs (<< 1.34-1)
207Provides: libext2fs2, libe2p2
208Architecture: any
209MULTIARCH_HEADERS
210Description: ext2/ext3/ext4 file system libraries
211 The ext2, ext3 and ext4 file systems are successors of the original ext
212 ("extended") file system. They are the main file system types used for
213 hard disks on Debian and other Linux systems.
214 .
215 This package provides the ext2fs and e2p libraries, for userspace software
216 that directly accesses extended file systems. Programs that use libext2fs
217 include e2fsck, mke2fs, and tune2fs. Programs that use libe2p include
218 dumpe2fs, chattr, and lsattr.
219
220Package: e2fslibs-dev
221Section: libdevel
222Priority: extra
223Depends: libc6-dev | libc-dev, comerr-dev, e2fslibs (= ${binary:Version}), ${misc:Depends}
224Suggests: doc-base
225Provides: ext2fs-dev, e2p-dev
226Replaces: libkrb5-dev (<< 1.3)
227Architecture: any
228Description: ext2/ext3/ext4 file system libraries - headers and static libraries
229 The ext2, ext3 and ext4 file systems are successors of the original ext
230 ("extended") file system. They are the main file system types used for
231 hard disks on Debian and other Linux systems.
232 .
233 This package contains the development environment for the ext2fs and e2p 
234 libraries.
235
236Package: e2fsprogs
237Essential: yes
238ifdef(`UTIL_LINUX_NG',
239``Pre-Depends: ${shlibs:Depends}, ${misc:Depends}, util-linux (>= 2.15~rc1-1)
240'',
241``Pre-Depends: ${shlibs:Depends}, ${misc:Depends}
242'')dnl
243Multi-Arch: foreign
244Suggests: gpart, parted, e2fsck-static
245Conflicts: dump (<< 0.4b4-4), quota (<< 1.55-8.1), initscripts (<< 2.85-4), sysvinit (<< 2.85-4)
246Replaces: hurd (<= 20040301-1), libblkid1 (<< 1.38+1.39-WIP-2005.12.10-2), libuuid1 (<< 1.38+1.39-WIP-2005.12.10-2)
247Architecture: any
248Description: ext2/ext3/ext4 file system utilities
249 The ext2, ext3 and ext4 file systems are successors of the original ext
250 ("extended") file system. They are the main file system types used for
251 hard disks on Debian and other Linux systems.
252 .
253 This package contains programs for creating, checking, and maintaining
254 ext2/3/4-based file systems.
255
256Package: e2fsprogs-dbg
257Section: debug
258Priority: extra
259Depends: e2fsprogs (= ${binary:Version}), ${misc:Depends}
260Architecture: any
261Description: debugging information for e2fsprogs
262 This package includes the debug information useful for debugging e2fsprogs
263 and its libraries, contained in the e2fsprogs and e2fsck-static packages.
264 The debug information is used for execution tracing and core
265 dump analysis. 
266ifdef(`UTIL_LINUX_NG',,``
267Package: uuid-runtime-dbg
268Section: debug
269Priority: extra
270Depends: uuid-runtime (= ${binary:Version}), ${misc:Depends}
271Architecture: any
272Description: debugging information for uuid-runtime
273 This package includes the debug information useful for debugging the
274 uuid runtime programs, contained in the uuid-runtime package.
275 The debugging information is used for execution tracing and core
276 dump analysis.
277'')dnl
278
279Package: e2fslibs-dbg
280Section: debug
281Priority: extra
282Depends: e2fslibs (= ${binary:Version}), ${misc:Depends}
283Architecture: any
284Description: debugging information for e2fslibs
285 This package includes the debug information useful for debugging the
286 ext2fs and e2p libraries, contained in the e2fslibs package.  The debug
287 information is used for execution tracing and core dump analysis.
288
289Package: libcomerr2-dbg
290Section: debug
291Priority: extra
292Depends: libcomerr2 (= ${binary:Version}), ${misc:Depends}
293Architecture: any
294Description: debugging information for libcomerr2
295 This package includes the debug information useful for debugging the
296 com_err library, contained in the libcomerr2 package.  The debugging
297 information is used for execution tracing and core dump analysis.
298
299Package: libss2-dbg
300Section: debug
301Priority: extra
302Depends: libss2 (= ${binary:Version}), ${misc:Depends}
303Architecture: any
304Description: debugging information for libss2
305 This package includes the debug information useful for debugging the
306 ss library, contained in the libss2 package.  The debug information
307 is used for execution tracing and core dump analysis.
308ifdef(`UTIL_LINUX_NG',,``
309Package: libblkid1-dbg
310Section: debug
311Priority: extra
312Depends: libblkid1 (= ${binary:Version}), ${misc:Depends}
313Architecture: any
314Description: debugging information for libblkid1
315 This package includes the debug information useful for debugging the
316 blkid library, contained in the libblkid1 package.  The debug
317 information is used for execution tracing and core dump analysis.
318
319Package: libuuid1-dbg
320Section: debug
321Priority: extra
322Depends: libuuid1 (= ${binary:Version}), ${misc:Depends}
323Architecture: any
324Description: debugging information for libuuid1
325 This package includes the debug information useful for debugging the
326 UUID library, contained in the libuuid1 package.  The debug
327 information is used for execution tracing and core dump analysis.
328'')dnl
329