1void glActiveTexture ( GLenum texture )
2void glAttachShader ( GLuint program, GLuint shader )
3void glBindAttribLocation ( GLuint program, GLuint index, const char *name )
4void glBindBuffer ( GLenum target, GLuint buffer )
5void glBindFramebuffer ( GLenum target, GLuint framebuffer )
6void glBindRenderbuffer ( GLenum target, GLuint renderbuffer )
7void glBindTexture ( GLenum target, GLuint texture )
8void glBlendColor ( GLclampf red, GLclampf green, GLclampf blue, GLclampf alpha )
9void glBlendEquation ( GLenum mode )
10void glBlendEquationSeparate ( GLenum modeRGB, GLenum modeAlpha )
11void glBlendFunc ( GLenum sfactor, GLenum dfactor )
12void glBlendFuncSeparate ( GLenum srcRGB, GLenum dstRGB, GLenum srcAlpha, GLenum dstAlpha )
13void glBufferData ( GLenum target, GLsizeiptr size, const GLvoid *data, GLenum usage )
14void glBufferSubData ( GLenum target, GLintptr offset, GLsizeiptr size, const GLvoid *data )
15GLenum glCheckFramebufferStatus ( GLenum target )
16void glClear ( GLbitfield mask )
17void glClearColor ( GLclampf red, GLclampf green, GLclampf blue, GLclampf alpha )
18void glClearDepthf ( GLclampf depth )
19void glClearStencil ( GLint s )
20void glColorMask ( GLboolean red, GLboolean green, GLboolean blue, GLboolean alpha )
21void glCompileShader ( GLuint shader )
22void glCompressedTexImage2D ( GLenum target, GLint level, GLenum internalformat, GLsizei width, GLsizei height, GLint border, GLsizei imageSize, const GLvoid *data )
23void glCompressedTexSubImage2D ( GLenum target, GLint level, GLint xoffset, GLint yoffset, GLsizei width, GLsizei height, GLenum format, GLsizei imageSize, const GLvoid *data )
24void glCopyTexImage2D ( GLenum target, GLint level, GLenum internalformat, GLint x, GLint y, GLsizei width, GLsizei height, GLint border )
25void glCopyTexSubImage2D ( GLenum target, GLint level, GLint xoffset, GLint yoffset, GLint x, GLint y, GLsizei width, GLsizei height )
26GLuint glCreateProgram ( void )
27GLuint glCreateShader ( GLenum type )
28void glCullFace ( GLenum mode )
29void glDeleteBuffers ( GLsizei n, const GLuint *buffers )
30void glDeleteFramebuffers ( GLsizei n, const GLuint *framebuffers )
31void glDeleteProgram ( GLuint program )
32void glDeleteRenderbuffers ( GLsizei n, const GLuint *renderbuffers )
33void glDeleteShader ( GLuint shader )
34void glDeleteTextures ( GLsizei n, const GLuint *textures )
35void glDepthFunc ( GLenum func )
36void glDepthMask ( GLboolean flag )
37void glDepthRangef ( GLclampf zNear, GLclampf zFar )
38void glDetachShader ( GLuint program, GLuint shader )
39void glDisable ( GLenum cap )
40void glDisableVertexAttribArray ( GLuint index )
41void glDrawArrays ( GLenum mode, GLint first, GLsizei count )
42void glDrawElements ( GLenum mode, GLsizei count, GLenum type, GLint offset )
43void glDrawElements ( GLenum mode, GLsizei count, GLenum type, const GLvoid *indices )
44void glEnable ( GLenum cap )
45void glEnableVertexAttribArray ( GLuint index )
46void glFinish ( void )
47void glFlush ( void )
48void glFramebufferRenderbuffer ( GLenum target, GLenum attachment, GLenum renderbuffertarget, GLuint renderbuffer )
49void glFramebufferTexture2D ( GLenum target, GLenum attachment, GLenum textarget, GLuint texture, GLint level )
50void glFrontFace ( GLenum mode )
51void glGenBuffers ( GLsizei n, GLuint *buffers )
52void glGenerateMipmap ( GLenum target )
53void glGenFramebuffers ( GLsizei n, GLuint *framebuffers )
54void glGenRenderbuffers ( GLsizei n, GLuint *renderbuffers )
55void glGenTextures ( GLsizei n, GLuint *textures )
56void glGetActiveAttrib ( GLuint program, GLuint index, GLsizei bufsize, GLsizei *length, GLint *size, GLenum *type, char *name )
57void glGetActiveUniform ( GLuint program, GLuint index, GLsizei bufsize, GLsizei *length, GLint *size, GLenum *type, char *name )
58void glGetAttachedShaders ( GLuint program, GLsizei maxcount, GLsizei *count, GLuint *shaders )
59GLint glGetAttribLocation ( GLuint program, const char *name )
60void glGetBooleanv ( GLenum pname, GLboolean *params )
61void glGetBufferParameteriv ( GLenum target, GLenum pname, GLint *params )
62GLenum glGetError ( void )
63void glGetFloatv ( GLenum pname, GLfloat *params )
64void glGetFramebufferAttachmentParameteriv ( GLenum target, GLenum attachment, GLenum pname, GLint *params )
65void glGetIntegerv ( GLenum pname, GLint *params )
66void glGetProgramiv ( GLuint program, GLenum pname, GLint *params )
67void glGetProgramInfoLog ( GLuint program, GLsizei bufsize, GLsizei *length, char *infolog )
68void glGetRenderbufferParameteriv ( GLenum target, GLenum pname, GLint *params )
69void glGetShaderiv ( GLuint shader, GLenum pname, GLint *params )
70void glGetShaderInfoLog ( GLuint shader, GLsizei bufsize, GLsizei *length, char *infolog )
71void glGetShaderPrecisionFormat ( GLenum shadertype, GLenum precisiontype, GLint *range, GLint *precision )
72void glGetShaderSource ( GLuint shader, GLsizei bufsize, GLsizei *length, char *source )
73const GLubyte * glGetString ( GLenum name )
74void glGetTexParameterfv ( GLenum target, GLenum pname, GLfloat *params )
75void glGetTexParameteriv ( GLenum target, GLenum pname, GLint *params )
76void glGetUniformfv ( GLuint program, GLint location, GLfloat *params )
77void glGetUniformiv ( GLuint program, GLint location, GLint *params )
78GLint glGetUniformLocation ( GLuint program, const char *name )
79void glGetVertexAttribfv ( GLuint index, GLenum pname, GLfloat *params )
80void glGetVertexAttribiv ( GLuint index, GLenum pname, GLint *params )
81// void glGetVertexAttribPointerv ( GLuint index, GLenum pname, void **pointer )
82void glHint ( GLenum target, GLenum mode )
83GLboolean glIsBuffer ( GLuint buffer )
84GLboolean glIsEnabled ( GLenum cap )
85GLboolean glIsFramebuffer ( GLuint framebuffer )
86GLboolean glIsProgram ( GLuint program )
87GLboolean glIsRenderbuffer ( GLuint renderbuffer )
88GLboolean glIsShader ( GLuint shader )
89GLboolean glIsTexture ( GLuint texture )
90void glLineWidth ( GLfloat width )
91void glLinkProgram ( GLuint program )
92void glPixelStorei ( GLenum pname, GLint param )
93void glPolygonOffset ( GLfloat factor, GLfloat units )
94void glReadPixels ( GLint x, GLint y, GLsizei width, GLsizei height, GLenum format, GLenum type, GLvoid *pixels )
95void glReleaseShaderCompiler ( void )
96void glRenderbufferStorage ( GLenum target, GLenum internalformat, GLsizei width, GLsizei height )
97void glSampleCoverage ( GLclampf value, GLboolean invert )
98void glScissor ( GLint x, GLint y, GLsizei width, GLsizei height )
99void glShaderBinary ( GLsizei n, const GLuint *shaders, GLenum binaryformat, const GLvoid *binary, GLsizei length )
100void glShaderSource ( GLuint shader )
101void glStencilFunc ( GLenum func, GLint ref, GLuint mask )
102void glStencilFuncSeparate ( GLenum face, GLenum func, GLint ref, GLuint mask )
103void glStencilMask ( GLuint mask )
104void glStencilMaskSeparate ( GLenum face, GLuint mask )
105void glStencilOp ( GLenum fail, GLenum zfail, GLenum zpass )
106void glStencilOpSeparate ( GLenum face, GLenum fail, GLenum zfail, GLenum zpass )
107void glTexImage2D ( GLenum target, GLint level, GLint internalformat, GLsizei width, GLsizei height, GLint border, GLenum format, GLenum type, const GLvoid *pixels )
108void glTexParameterf ( GLenum target, GLenum pname, GLfloat param )
109void glTexParameterfv ( GLenum target, GLenum pname, const GLfloat *params )
110void glTexParameteri ( GLenum target, GLenum pname, GLint param )
111void glTexParameteriv ( GLenum target, GLenum pname, const GLint *params )
112void glTexSubImage2D ( GLenum target, GLint level, GLint xoffset, GLint yoffset, GLsizei width, GLsizei height, GLenum format, GLenum type, const GLvoid *pixels )
113void glUniform1f ( GLint location, GLfloat x )
114void glUniform1fv ( GLint location, GLsizei count, const GLfloat *v )
115void glUniform1i ( GLint location, GLint x )
116void glUniform1iv ( GLint location, GLsizei count, const GLint *v )
117void glUniform2f ( GLint location, GLfloat x, GLfloat y )
118void glUniform2fv ( GLint location, GLsizei count, const GLfloat *v )
119void glUniform2i ( GLint location, GLint x, GLint y )
120void glUniform2iv ( GLint location, GLsizei count, const GLint *v )
121void glUniform3f ( GLint location, GLfloat x, GLfloat y, GLfloat z )
122void glUniform3fv ( GLint location, GLsizei count, const GLfloat *v )
123void glUniform3i ( GLint location, GLint x, GLint y, GLint z )
124void glUniform3iv ( GLint location, GLsizei count, const GLint *v )
125void glUniform4f ( GLint location, GLfloat x, GLfloat y, GLfloat z, GLfloat w )
126void glUniform4fv ( GLint location, GLsizei count, const GLfloat *v )
127void glUniform4i ( GLint location, GLint x, GLint y, GLint z, GLint w )
128void glUniform4iv ( GLint location, GLsizei count, const GLint *v )
129void glUniformMatrix2fv ( GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
130void glUniformMatrix3fv ( GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
131void glUniformMatrix4fv ( GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
132void glUseProgram ( GLuint program )
133void glValidateProgram ( GLuint program )
134void glVertexAttrib1f ( GLuint indx, GLfloat x )
135void glVertexAttrib1fv ( GLuint indx, const GLfloat *values )
136void glVertexAttrib2f ( GLuint indx, GLfloat x, GLfloat y )
137void glVertexAttrib2fv ( GLuint indx, const GLfloat *values )
138void glVertexAttrib3f ( GLuint indx, GLfloat x, GLfloat y, GLfloat z )
139void glVertexAttrib3fv ( GLuint indx, const GLfloat *values )
140void glVertexAttrib4f ( GLuint indx, GLfloat x, GLfloat y, GLfloat z, GLfloat w )
141void glVertexAttrib4fv ( GLuint indx, const GLfloat *values )
142void glVertexAttribPointer ( GLuint indx, GLint size, GLenum type, GLboolean normalized, GLsizei stride, GLint offset )
143void glVertexAttribPointer ( GLuint indx, GLint size, GLenum type, GLboolean normalized, GLsizei stride, const GLvoid *ptr )
144void glViewport ( GLint x, GLint y, GLsizei width, GLsizei height )
145