Lines Matching refs:to

10 # Unless required by applicable law or agreed to in writing, software
20 The @rsForEach() function can be used to invoke the root kernel of a script.
22 The other functions are used to get the characteristics of the invocation of
38 This type is used to suggest how the invoked kernel should iterate over the cells of the
48 summary: Handle to a kernel invocation context
58 rs_kernel_context to your kernel function. See @rsGetDimX() and @rsGetArray0() for examples.
80 This structure is used to provide iteration information to a rsForEach call.
81 It is currently used to restrict processing to a subset of cells. In future
82 versions, it will also be used to provide hint on how to best iterate over
85 The Start fields are inclusive and the End fields are exclusive. E.g. to iterate
86 over cells 4, 5, 6, and 7 in the X dimension, set xStart to 4 and xEnd to 8.
92 arg: rs_script script, "Script to call."
93 arg: rs_allocation input, "Allocation to source data from."
94 arg: rs_allocation output, "Allocation to write date into."
95 arg: const void* usrData, "User defined data to pass to the script. May be NULL."
96 arg: const rs_script_call_t* sc, "Extra control information used to select a sub-region of the allocation to be processed or suggest a walking strategy. May be NULL."
104 only when the script has completed and the output allocation is ready to use.
137 arg: size_t usrDataLen, "Size of the userData structure. This will be used to perform a shallow copy of the data if necessary."
176 type rs_kernel_context to your kernel function. E.g.<br/>
180 &nbsp;&nbsp;// to the other dimensions, extract them from the context:<br/>
239 #TODO Add an hyperlink to something that explains Array0/1/2/3
289 If the context refers to a cubemap, this function returns true if there's more than
326 type rs_kernel_context to your kernel function. E.g.<br/>