1c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouillet#
2c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouillet# Copyright (C) 2015 The Android Open Source Project
3c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouillet#
4c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouillet# Licensed under the Apache License, Version 2.0 (the "License");
5c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouillet# you may not use this file except in compliance with the License.
6c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouillet# You may obtain a copy of the License at
7c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouillet#
8c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouillet#      http://www.apache.org/licenses/LICENSE-2.0
9c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouillet#
10c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouillet# Unless required by applicable law or agreed to in writing, software
11c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouillet# distributed under the License is distributed on an "AS IS" BASIS,
12c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouillet# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouillet# See the License for the specific language governing permissions and
14c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouillet# limitations under the License.
15c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouillet#
16c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouillet
17c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouilletheader:
1820b27d602a4778ed50a83df2147416a35b7c92beJean-Luc Brouilletsummary: Overview
19c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouilletdescription:
202217eb7b12e598e5b435a732207647918c171560Jean-Luc Brouillet RenderScript is a high-performance runtime that provides compute operations at the native level.
212217eb7b12e598e5b435a732207647918c171560Jean-Luc Brouillet RenderScript code is compiled on devices at runtime to allow platform-independence as well.
222217eb7b12e598e5b435a732207647918c171560Jean-Luc Brouillet
232217eb7b12e598e5b435a732207647918c171560Jean-Luc Brouillet This reference documentation describes the RenderScript runtime APIs, which you can utilize
242217eb7b12e598e5b435a732207647918c171560Jean-Luc Brouillet to write RenderScript code in C99. The RenderScript compute header files are automatically
252217eb7b12e598e5b435a732207647918c171560Jean-Luc Brouillet included for you.
26c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouillet
2701c19c30a73d4a3ad42ad5630ad790db01a853ccJean-Luc Brouillet To use RenderScript, you need to utilize the RenderScript runtime APIs documented here as well
2801c19c30a73d4a3ad42ad5630ad790db01a853ccJean-Luc Brouillet as the Android framework APIs for RenderScript.  For documentation on the Android framework
2901c19c30a73d4a3ad42ad5630ad790db01a853ccJean-Luc Brouillet APIs, see the <a target="_parent" href="http://developer.android.com/reference/android/renderscript/package-summary.html">android.renderscript</a> package reference.
302217eb7b12e598e5b435a732207647918c171560Jean-Luc Brouillet
3101c19c30a73d4a3ad42ad5630ad790db01a853ccJean-Luc Brouillet For more information on how to develop with RenderScript and how the runtime and Android
3201c19c30a73d4a3ad42ad5630ad790db01a853ccJean-Luc Brouillet framework APIs interact, see the <a target="_parent" href="http://developer.android.com/guide/topics/renderscript/index.html">RenderScript developer guide</a> and the <a target="_parent" href="http://developer.android.com/resources/samples/RenderScript/index.html">RenderScript samples</a>.
33c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouilletinclude:
34c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouillet #define RS_KERNEL __attribute__((kernel))
35c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouillet
36be2163801c33d6849ae580d42b919b8803d55095Jean-Luc Brouillet #include "stdbool.h"
37be2163801c33d6849ae580d42b919b8803d55095Jean-Luc Brouillet
38be2163801c33d6849ae580d42b919b8803d55095Jean-Luc Brouillet #include "rs_value_types.rsh"
39be2163801c33d6849ae580d42b919b8803d55095Jean-Luc Brouillet #include "rs_object_types.rsh"
40be2163801c33d6849ae580d42b919b8803d55095Jean-Luc Brouillet
41be2163801c33d6849ae580d42b919b8803d55095Jean-Luc Brouillet #include "rs_allocation_data.rsh"
42c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouillet #include "rs_atomic.rsh"
43be2163801c33d6849ae580d42b919b8803d55095Jean-Luc Brouillet #include "rs_convert.rsh"
44c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouillet #include "rs_debug.rsh"
45be2163801c33d6849ae580d42b919b8803d55095Jean-Luc Brouillet #include "rs_for_each.rsh"
46be2163801c33d6849ae580d42b919b8803d55095Jean-Luc Brouillet #include "rs_io.rsh"
47c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouillet #include "rs_math.rsh"
48c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouillet #include "rs_matrix.rsh"
49be2163801c33d6849ae580d42b919b8803d55095Jean-Luc Brouillet #include "rs_object_info.rsh"
50c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouillet #include "rs_quaternion.rsh"
51c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouillet #include "rs_time.rsh"
52be2163801c33d6849ae580d42b919b8803d55095Jean-Luc Brouillet #include "rs_vector_math.rsh"
53c5184e202ced435258adb2cfe2013570e7190954Jean-Luc Brouilletend:
54