Lines Matching refs:arg

52 arg: const rs_matrix4x4* viewProj, "Matrix to extract planes from."
53 arg: float4* left, "Left plane."
54 arg: float4* right, "Right plane."
55 arg: float4* top, "Top plane."
56 arg: float4* bottom, "Bottom plane."
57 arg: float4* near, "Near plane."
58 arg: float4* far, "Far plane."
112 arg: float4* sphere, "float4 representing the sphere."
113 arg: float4* left, "Left plane."
114 arg: float4* right, "Right plane."
115 arg: float4* top, "Top plane."
116 arg: float4* bottom, "Bottom plane."
117 arg: float4* near, "Near plane."
118 arg: float4* far, "Far plane."
154 arg: const #1* m, "Matrix to extract the element from."
155 arg: uint32_t col, "Zero-based column of the element to be extracted."
156 arg: uint32_t row, "Zero-based row of the element to extracted."
167 arg: rs_matrix4x4* m, "Matrix to invert."
176 arg: rs_matrix4x4* m, "Matrix to modify."
187 arg: #1* destination, "Matrix to set."
188 arg: const float* array, "Array of values to set the matrix to. These arrays should be 4, 9, or 16 floats long, depending on the matrix size."
212 arg: #1* destination
213 arg: const #1* source, "Source matrix."
220 arg: rs_matrix4x4* destination
221 arg: const #1* source
227 arg: rs_matrix4x4* m, "Matrix to set."
228 arg: float left
229 arg: float right
230 arg: float bottom
231 arg: float top
232 arg: float near
233 arg: float far
247 arg: #1* m, "Matrix to set."
257 arg: #1* m, "Matrix to set."
258 arg: const #1* lhs, "Left matrix of the product."
259 arg: const #1* rhs, "Right matrix of the product."
277 arg: rs_matrix4x4* m, "Matrix to set."
278 arg: float left
279 arg: float right
280 arg: float bottom
281 arg: float top
282 arg: float near
283 arg: float far
299 arg: rs_matrix4x4* m, "Matrix to set."
300 arg: float fovy, "Field of view, in degrees along the Y axis."
301 arg: float aspect, "Ratio of x / y."
302 arg: float near, "Near clipping plane."
303 arg: float far, "Far clipping plane."
315 arg: rs_matrix4x4* m, "Matrix to set."
316 arg: float rot, "How much rotation to do, in degrees."
317 arg: float x, "X component of the vector that is the axis of rotation."
318 arg: float y, "Y component of the vector that is the axis of rotation."
319 arg: float z, "Z component of the vector that is the axis of rotation."
332 arg: rs_matrix4x4* m, "Matrix to set."
333 arg: float x, "Multiple to scale the x components by."
334 arg: float y, "Multiple to scale the y components by."
335 arg: float z, "Multiple to scale the z components by."
347 arg: rs_matrix4x4* m, "Matrix to set."
348 arg: float x, "Number to add to each x component."
349 arg: float y, "Number to add to each y component."
350 arg: float z, "Number to add to each z component."
364 arg: #1* m, "Left matrix of the product and the matrix to be set."
365 arg: const #1* rhs, "Right matrix of the product."
390 arg: rs_matrix4x4* m
391 arg: float4 in
398 arg: rs_matrix4x4* m
399 arg: float3 in
406 arg: rs_matrix4x4* m
407 arg: float2 in
414 arg: rs_matrix3x3* m
415 arg: float3 in
422 arg: rs_matrix3x3* m
423 arg: float2 in
430 arg: rs_matrix2x2* m
431 arg: float2 in
438 arg: const rs_matrix4x4* m
439 arg: float4 in
446 arg: const rs_matrix4x4* m
447 arg: float3 in
454 arg: const rs_matrix4x4* m
455 arg: float2 in
462 arg: const rs_matrix3x3* m
463 arg: float3 in
470 arg: const rs_matrix3x3* m
471 arg: float2 in
478 arg: const rs_matrix2x2* m
479 arg: float2 in
485 arg: rs_matrix4x4* m, "Matrix to modify."
486 arg: float rot, "How much rotation to do, in degrees."
487 arg: float x, "X component of the vector that is the axis of rotation."
488 arg: float y, "Y component of the vector that is the axis of rotation."
489 arg: float z, "Z component of the vector that is the axis of rotation."
504 arg: rs_matrix4x4* m, "Matrix to modify."
505 arg: float x, "Multiple to scale the x components by."
506 arg: float y, "Multiple to scale the y components by."
507 arg: float z, "Multiple to scale the z components by."
523 arg: #1* m, "Matrix that will be modified."
524 arg: uint32_t col, "Zero-based column of the element to be set."
525 arg: uint32_t row, "Zero-based row of the element to be set."
526 arg: float v, "Value to set."
537 arg: rs_matrix4x4* m, "Matrix to modify."
538 arg: float x, "Number to add to each x component."
539 arg: float y, "Number to add to each y component."
540 arg: float z, "Number to add to each z component."
556 arg: #1 m, "Matrix to transpose."