Lines Matching refs:of

6 # You may obtain a copy of the License at
20 The functions below can be used to query the characteristics of an Allocation, Element,
28 They are a structured collection of cells that can be used to store bitmaps, textures,
31 This collection of cells may have many dimensions (X, Y, Z, Array0, Array1, Array2, Array3),
32 faces (for cubemaps), and level of details (for mipmapping).
39 for the cells of an Allocation and the instantiation of that type. For example:<ul>
41 <li>In functions like @rsGetElementAt(), "element" means the instantiation of the type,
42 i.e. a cell of an Allocation.</li></ul>
44 The functions below let you query the characteristics of the type specificiation.
48 a list of basic types.
50 Elements can specify fixed size vector (of size 2, 3, or 4) versions of the basic types.
51 Elements can be grouped together into complex Elements, creating the equivalent of
57 When creating Allocations of common elements, you can simply use one of the many predefined
71 summary: Presence of more than one face
76 Use @rsGetDimHasFaces() to get the dimension of a currently running kernel.
83 summary: Presence of levels of detail
85 Query an Allocation for the presence of more than one Level Of Detail. This is useful
88 Use @rsGetDimLod() to get the dimension of a currently running kernel.
93 ret: uint32_t, "X dimension of the Allocation."
95 summary: Size of the X dimension
97 Returns the size of the X dimension of the Allocation.
99 Use @rsGetDimX() to get the dimension of a currently running kernel.
104 ret: uint32_t, "Y dimension of the Allocation."
106 summary: Size of the Y dimension
108 Returns the size of the Y dimension of the Allocation. If the Allocation has less
111 Use @rsGetDimY() to get the dimension of a currently running kernel.
116 ret: uint32_t, "Z dimension of the Allocation."
118 summary: Size of the Z dimension
120 Returns the size of the Z dimension of the Allocation. If the Allocation has less
123 Use @rsGetDimZ() to get the dimension of a currently running kernel.
130 summary: Get the object that describes the cell of an Allocation
132 Get the Element object describing the type, kind, and other characteristics of a cell
133 of an Allocation. See the rsElement* functions below.
170 summary: Size of an Element
172 Returns the size in bytes that an instantiation of this Element will occupy.
180 summary: Kind of an Element
192 summary: Data type of an Element
199 If the Element describes a vector, this function returns the data type of one of its items.
200 Use @rsElementGetVectorSize to get the size of the vector.
211 arg: uint32_t index, "Index of the sub-element to return."
212 summary: Sub-element of a complex Element
217 If the Element is not a structure or the index is greater or equal to the number of
224 ret: uint32_t, "Array size of the sub-element."
226 arg: uint32_t index, "Index of the sub-element."
227 summary: Array size of a sub-element of a complex Element
230 returns the array size of the sub-element at the index. This sub-element repetition
237 ret: uint32_t, "Number of sub-elements."
239 summary: Number of sub-elements
242 sub-elements. This function returns zero for simple Elements and the number of
249 ret: uint32_t, "Number of characters copied, excluding the null terminator."
251 arg: uint32_t index, "Index of the sub-element."
252 arg: char* name, "Address of the array to store the name into."
253 arg: uint32_t nameLength, "Length of the provided name array."
254 summary: Name of a sub-element
256 For complex Elements, this function returns the name of the sub-element at the
263 ret: uint32_t, "Length of the sub-element name including the null terminator."
265 arg: uint32_t index, "Index of the sub-element."
266 summary: Length of the name of a sub-element
268 For complex Elements, this function returns the length of the name of the sub-element
277 arg: uint32_t index, "Index of the sub-element."
278 summary: Offset of the instantiated sub-element
280 This function returns the relative position of the instantiation of the specified
281 sub-element within the instantiation of the Element.
290 ret: uint32_t, "Length of the element vector."
292 summary: Vector size of the Element
314 summary: Anisotropy of the Sampler