rs_debug.spec revision 6ba05171a84a7444df01b9f81a7233b17e1f120a
1#
2# Copyright (C) 2015 The Android Open Source Project
3#
4# Licensed under the Apache License, Version 2.0 (the "License");
5# you may not use this file except in compliance with the License.
6# You may obtain a copy of the License at
7#
8#      http://www.apache.org/licenses/LICENSE-2.0
9#
10# Unless required by applicable law or agreed to in writing, software
11# distributed under the License is distributed on an "AS IS" BASIS,
12# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13# See the License for the specific language governing permissions and
14# limitations under the License.
15#
16
17header:
18summary: Debugging Functions
19description:
20 The functions below are intended to be used during application developement.
21 They should not be used in shipping applications.
22include:
23 #define RS_DEBUG(a) rsDebug(#a, a)
24 #define RS_DEBUG_MARKER rsDebug(__FILE__, __LINE__)
25end:
26
27function: rsDebug
28t: i32, u32, i64, u64, f64
29ret: void
30arg: const char* message
31arg: #1 a
32summary: Log a message and values
33description:
34 This function prints a message to the standard log, followed by the provided values.
35
36 This function is intended for debugging only and should not be used in shipping
37 applications.
38test: none
39end:
40
41function: rsDebug
42version: 17
43w: 2, 3, 4
44t: i32, u32, i64, u64
45ret: void
46arg: const char* message
47arg: #2#1 a
48test: none
49end:
50
51function: rsDebug
52version: 23
53w: 2, 3, 4
54t: f64
55ret: void
56arg: const char* message
57arg: #2#1 a
58test: none
59end:
60
61function: rsDebug
62w: 1, 2, 3, 4
63ret: void
64arg: const char* message
65arg: float#1 a
66test: none
67end:
68
69function: rsDebug
70version: 17
71w: 1, 2, 3, 4
72t: i8, u8, i16, u16
73ret: void
74arg: const char* message
75arg: #2#1 a
76test: none
77end:
78
79function: rsDebug
80ret: void
81arg: const char* message
82arg: float a
83arg: float b
84test: none
85end:
86
87function: rsDebug
88ret: void
89arg: const char* message
90arg: float a
91arg: float b
92arg: float c
93test: none
94end:
95
96function: rsDebug
97ret: void
98arg: const char* message
99arg: float a
100arg: float b
101arg: float c
102arg: float d
103test: none
104end:
105
106function: rsDebug
107ret: void
108arg: const char* message
109arg: long long a
110test: none
111end:
112
113function: rsDebug
114ret: void
115arg: const char* message
116arg: unsigned long long a
117test: none
118end:
119
120function: rsDebug
121ret: void
122arg: const char* message
123arg: const void* a
124test: none
125end:
126
127function: rsDebug
128ret: void
129arg: const char* message
130arg: const rs_matrix4x4* a
131test: none
132end:
133
134function: rsDebug
135ret: void
136arg: const char* message
137arg: const rs_matrix3x3* a
138test: none
139end:
140
141function: rsDebug
142ret: void
143arg: const char* message
144arg: const rs_matrix2x2* a
145test: none
146end:
147
148#define RS_DEBUG(a) rsDebug(#a, a)
149#define RS_DEBUG_MARKER rsDebug(__FILE__, __LINE__)
150