Lines Matching refs:GLsizei

22 void glCompressedTexImage2D ( GLenum target, GLint level, GLenum internalformat, GLsizei width, GLsizei height, GLint border, GLsizei imageSize, const GLvoid *data )
23 void glCompressedTexSubImage2D ( GLenum target, GLint level, GLint xoffset, GLint yoffset, GLsizei width, GLsizei height, GLenum format, GLsizei imageSize, const GLvoid *data )
24 void glCopyTexImage2D ( GLenum target, GLint level, GLenum internalformat, GLint x, GLint y, GLsizei width, GLsizei height, GLint border )
25 void glCopyTexSubImage2D ( GLenum target, GLint level, GLint xoffset, GLint yoffset, GLint x, GLint y, GLsizei width, GLsizei height )
29 void glDeleteBuffers ( GLsizei n, const GLuint *buffers )
30 void glDeleteFramebuffers ( GLsizei n, const GLuint *framebuffers )
32 void glDeleteRenderbuffers ( GLsizei n, const GLuint *renderbuffers )
34 void glDeleteTextures ( GLsizei n, const GLuint *textures )
41 void glDrawArrays ( GLenum mode, GLint first, GLsizei count )
42 void glDrawElements ( GLenum mode, GLsizei count, GLenum type, GLint offset )
43 void glDrawElements ( GLenum mode, GLsizei count, GLenum type, const GLvoid *indices )
51 void glGenBuffers ( GLsizei n, GLuint *buffers )
53 void glGenFramebuffers ( GLsizei n, GLuint *framebuffers )
54 void glGenRenderbuffers ( GLsizei n, GLuint *renderbuffers )
55 void glGenTextures ( GLsizei n, GLuint *textures )
56 void glGetActiveAttrib ( GLuint program, GLuint index, GLsizei bufsize, GLsizei *length, GLint *size, GLenum *type, char *name )
57 void glGetActiveUniform ( GLuint program, GLuint index, GLsizei bufsize, GLsizei *length, GLint *size, GLenum *type, char *name )
58 void glGetAttachedShaders ( GLuint program, GLsizei maxcount, GLsizei *count, GLuint *shaders )
67 void glGetProgramInfoLog ( GLuint program, GLsizei bufsize, GLsizei *length, char *infolog )
70 void glGetShaderInfoLog ( GLuint shader, GLsizei bufsize, GLsizei *length, char *infolog )
72 void glGetShaderSource ( GLuint shader, GLsizei bufsize, GLsizei *length, char *source )
94 void glReadPixels ( GLint x, GLint y, GLsizei width, GLsizei height, GLenum format, GLenum type, GLvoid *pixels )
96 void glRenderbufferStorage ( GLenum target, GLenum internalformat, GLsizei width, GLsizei height )
98 void glScissor ( GLint x, GLint y, GLsizei width, GLsizei height )
99 void glShaderBinary ( GLsizei n, const GLuint *shaders, GLenum binaryformat, const GLvoid *binary, GLsizei length )
107 void glTexImage2D ( GLenum target, GLint level, GLint internalformat, GLsizei width, GLsizei height, GLint border, GLenum format, GLenum type, const GLvoid *pixels )
112 void glTexSubImage2D ( GLenum target, GLint level, GLint xoffset, GLint yoffset, GLsizei width, GLsizei height, GLenum format, GLenum type, const GLvoid *pixels )
114 void glUniform1fv ( GLint location, GLsizei count, const GLfloat *v )
116 void glUniform1iv ( GLint location, GLsizei count, const GLint *v )
118 void glUniform2fv ( GLint location, GLsizei count, const GLfloat *v )
120 void glUniform2iv ( GLint location, GLsizei count, const GLint *v )
122 void glUniform3fv ( GLint location, GLsizei count, const GLfloat *v )
124 void glUniform3iv ( GLint location, GLsizei count, const GLint *v )
126 void glUniform4fv ( GLint location, GLsizei count, const GLfloat *v )
128 void glUniform4iv ( GLint location, GLsizei count, const GLint *v )
129 void glUniformMatrix2fv ( GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
130 void glUniformMatrix3fv ( GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
131 void glUniformMatrix4fv ( GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
142 void glVertexAttribPointer ( GLuint indx, GLint size, GLenum type, GLboolean normalized, GLsizei stride, GLint offset )
143 void glVertexAttribPointer ( GLuint indx, GLint size, GLenum type, GLboolean normalized, GLsizei stride, const GLvoid *ptr )
144 void glViewport ( GLint x, GLint y, GLsizei width, GLsizei height )