Lines Matching refs:GLuint

1 void glDispatchCompute ( GLuint num_groups_x, GLuint num_groups_y, GLuint num_groups_z )
7 void glGetProgramInterfaceiv ( GLuint program, GLenum programInterface, GLenum pname, GLint *params )
8 GLuint glGetProgramResourceIndex ( GLuint program, GLenum programInterface, const GLchar *name )
9 void glGetProgramResourceName ( GLuint program, GLenum programInterface, GLuint index, GLsizei bufSize, GLsizei *length, GLchar *name )
10 void glGetProgramResourceiv ( GLuint program, GLenum programInterface, GLuint index, GLsizei propCount, const GLenum *props, GLsizei bufSize, GLsizei *length, GLint *params )
11 GLint glGetProgramResourceLocation ( GLuint program, GLenum programInterface, const GLchar *name )
12 void glUseProgramStages ( GLuint pipeline, GLbitfield stages, GLuint program )
13 void glActiveShaderProgram ( GLuint pipeline, GLuint program )
14 GLuint glCreateShaderProgramv ( GLenum type, GLsizei count, const GLchar *const *strings )
15 void glBindProgramPipeline ( GLuint pipeline )
16 void glDeleteProgramPipelines ( GLsizei n, const GLuint *pipelines )
17 void glGenProgramPipelines ( GLsizei n, GLuint *pipelines )
18 GLboolean glIsProgramPipeline ( GLuint pipeline )
19 void glGetProgramPipelineiv ( GLuint pipeline, GLenum pname, GLint *params )
20 void glProgramUniform1i ( GLuint program, GLint location, GLint v0 )
21 void glProgramUniform2i ( GLuint program, GLint location, GLint v0, GLint v1 )
22 void glProgramUniform3i ( GLuint program, GLint location, GLint v0, GLint v1, GLint v2 )
23 void glProgramUniform4i ( GLuint program, GLint location, GLint v0, GLint v1, GLint v2, GLint v3 )
24 void glProgramUniform1ui ( GLuint program, GLint location, GLuint v0 )
25 void glProgramUniform2ui ( GLuint program, GLint location, GLuint v0, GLuint v1 )
26 void glProgramUniform3ui ( GLuint program, GLint location, GLuint v0, GLuint v1, GLuint v2 )
27 void glProgramUniform4ui ( GLuint program, GLint location, GLuint v0, GLuint v1, GLuint v2, GLuint v3 )
28 void glProgramUniform1f ( GLuint program, GLint location, GLfloat v0 )
29 void glProgramUniform2f ( GLuint program, GLint location, GLfloat v0, GLfloat v1 )
30 void glProgramUniform3f ( GLuint program, GLint location, GLfloat v0, GLfloat v1, GLfloat v2 )
31 void glProgramUniform4f ( GLuint program, GLint location, GLfloat v0, GLfloat v1, GLfloat v2, GLfloat v3 )
32 void glProgramUniform1iv ( GLuint program, GLint location, GLsizei count, const GLint *value )
33 void glProgramUniform2iv ( GLuint program, GLint location, GLsizei count, const GLint *value )
34 void glProgramUniform3iv ( GLuint program, GLint location, GLsizei count, const GLint *value )
35 void glProgramUniform4iv ( GLuint program, GLint location, GLsizei count, const GLint *value )
36 void glProgramUniform1uiv ( GLuint program, GLint location, GLsizei count, const GLuint *value )
37 void glProgramUniform2uiv ( GLuint program, GLint location, GLsizei count, const GLuint *value )
38 void glProgramUniform3uiv ( GLuint program, GLint location, GLsizei count, const GLuint *value )
39 void glProgramUniform4uiv ( GLuint program, GLint location, GLsizei count, const GLuint *value )
40 void glProgramUniform1fv ( GLuint program, GLint location, GLsizei count, const GLfloat *value )
41 void glProgramUniform2fv ( GLuint program, GLint location, GLsizei count, const GLfloat *value )
42 void glProgramUniform3fv ( GLuint program, GLint location, GLsizei count, const GLfloat *value )
43 void glProgramUniform4fv ( GLuint program, GLint location, GLsizei count, const GLfloat *value )
44 void glProgramUniformMatrix2fv ( GLuint program, GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
45 void glProgramUniformMatrix3fv ( GLuint program, GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
46 void glProgramUniformMatrix4fv ( GLuint program, GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
47 void glProgramUniformMatrix2x3fv ( GLuint program, GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
48 void glProgramUniformMatrix3x2fv ( GLuint program, GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
49 void glProgramUniformMatrix2x4fv ( GLuint program, GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
50 void glProgramUniformMatrix4x2fv ( GLuint program, GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
51 void glProgramUniformMatrix3x4fv ( GLuint program, GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
52 void glProgramUniformMatrix4x3fv ( GLuint program, GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
53 void glValidateProgramPipeline ( GLuint pipeline )
54 void glGetProgramPipelineInfoLog ( GLuint pipeline, GLsizei bufSize, GLsizei *length, GLchar *infoLog )
55 void glBindImageTexture ( GLuint unit, GLuint texture, GLint level, GLboolean layered, GLint layer, GLenum access, GLenum format )
56 void glGetBooleani_v ( GLenum target, GLuint index, GLboolean *data )
60 void glGetMultisamplefv ( GLenum pname, GLuint index, GLfloat *val )
61 void glSampleMaski ( GLuint maskNumber, GLbitfield mask )
64 void glBindVertexBuffer ( GLuint bindingindex, GLuint buffer, GLintptr offset, GLsizei stride )
65 void glVertexAttribFormat ( GLuint attribindex, GLint size, GLenum type, GLboolean normalized, GLuint relativeoffset )
66 void glVertexAttribIFormat ( GLuint attribindex, GLint size, GLenum type, GLuint relativeoffset )
67 void glVertexAttribBinding ( GLuint attribindex, GLuint bindingindex )
68 void glVertexBindingDivisor ( GLuint bindingindex, GLuint divisor )