Lines Matching refs:value

37 arg: volatile int32_t* addr, "Address of the value to modify."
38 arg: int32_t value, "Amount to add."
41 Atomicly adds a value to the value at addr, i.e. <code>*addr += value</code>.
49 arg: uint32_t value
56 arg: volatile int32_t* addr, "Address of the value to modify."
57 arg: int32_t value, "Value to and with."
61 i.e. <code>*addr &amp;= value</code>.
69 arg: uint32_t value
76 arg: volatile int32_t* addr, "Address of the value to compare and replace if the test passes."
81 If the value at addr matches compareValue then the newValue is written at addr,
84 You can check that the value was written by checking that the value returned
101 arg: volatile int32_t* addr, "Address of the value to decrement."
104 Atomicly subtracts one from the value at addr. This is equivalent to <code>@rsAtomicSub(addr, 1)</code>.
118 arg: volatile int32_t* addr, "Address of the value to increment."
121 Atomicly adds one to the value at addr. This is equivalent to <code>@rsAtomicAdd(addr, 1)</code>.
135 arg: volatile uint32_t* addr, "Address of the value to modify."
136 arg: uint32_t value, "Comparison value."
139 Atomicly sets the value at addr to the maximum of *addr and value, i.e.
140 <code>*addr = max(*addr, value)</code>.
148 arg: int32_t value
155 arg: volatile uint32_t* addr, "Address of the value to modify."
156 arg: uint32_t value, "Comparison value."
159 Atomicly sets the value at addr to the minimum of *addr and value, i.e.
160 <code>*addr = min(*addr, value)</code>.
168 arg: int32_t value
175 arg: volatile int32_t* addr, "Address of the value to modify."
176 arg: int32_t value, "Value to or with."
180 i.e. <code>*addr |= value</code>.
188 arg: uint32_t value
195 arg: volatile int32_t* addr, "Address of the value to modify."
196 arg: int32_t value, "Amount to subtract."
199 Atomicly subtracts a value from the value at addr, i.e. <code>*addr -= value</code>.
207 arg: uint32_t value
214 arg: volatile int32_t* addr, "Address of the value to modify."
215 arg: int32_t value, "Value to xor with."
219 i.e. <code>*addr ^= value</code>.
227 arg: uint32_t value