Lines Matching refs:to

10 # Unless required by applicable law or agreed to in writing, software
20 The types below are used to manipulate RenderScript objects like allocations, samplers,
25 // Opaque handle to a RenderScript object. Do not use this directly.
44 summary: Handle to an element
46 An opaque handle to a RenderScript element.
53 summary: Handle to a Type
55 An opaque handle to a RenderScript type.
62 summary: Handle to an allocation
64 An opaque handle to a RenderScript allocation.
71 summary: Handle to a Sampler
73 An opaque handle to a RenderScript sampler object.
80 summary: Handle to a Script
82 An opaque handle to a RenderScript script object.
98 An enum used to specify one the six faces of a cubemap.
104 value: RS_ALLOCATION_USAGE_SCRIPT = 0x0001, "Allocation is bound to and accessed by scripts."
111 value: RS_ALLOCATION_USAGE_SHARED = 0x0080, "Allocation's backing store is shared with another object (usually a Bitmap). Copying to or from the original source Bitmap will cause a synchronization rather than a full copy."
112 summary: Bitfield to specify how an allocation is used
114 These values are ORed together to specify which usages or memory spaces are
115 relevant to an allocation or an operation on an allocation.
140 value: RS_TYPE_ELEMENT = 1000, "A handle to an Element."
141 value: RS_TYPE_TYPE = 1001, "A handle to a Type."
142 value: RS_TYPE_ALLOCATION = 1002, "A handle to an Allocation."
143 value: RS_TYPE_SAMPLER = 1003, "A handle to a Sampler."
144 value: RS_TYPE_SCRIPT = 1004, "A handle to a Script."
154 rs_data_type is used to encode the type information of a basic element.
175 This enumeration is primarly useful for graphical data. It provides additional information to