1EGLint eglGetError ( void )
2EGLDisplay eglGetDisplay ( EGLNativeDisplayType display_id )
3EGLBoolean eglInitialize ( EGLDisplay dpy, EGLint *major, EGLint *minor )
4EGLBoolean eglTerminate ( EGLDisplay dpy )
5const char * eglQueryString ( EGLDisplay dpy, EGLint name )
6EGLBoolean eglGetConfigs ( EGLDisplay dpy, EGLConfig *configs, EGLint config_size, EGLint *num_config )
7EGLBoolean eglChooseConfig ( EGLDisplay dpy, const EGLint *attrib_list, EGLConfig *configs, EGLint config_size, EGLint *num_config )
8EGLBoolean eglGetConfigAttrib ( EGLDisplay dpy, EGLConfig config, EGLint attribute, EGLint *value )
9EGLSurface eglCreateWindowSurface ( EGLDisplay dpy, EGLConfig config, EGLNativeWindowType win, const EGLint *attrib_list )
10EGLSurface eglCreatePbufferSurface ( EGLDisplay dpy, EGLConfig config, const EGLint *attrib_list )
11EGLSurface eglCreatePixmapSurface ( EGLDisplay dpy, EGLConfig config, EGLNativePixmapType pixmap, const EGLint *attrib_list )
12EGLBoolean eglDestroySurface ( EGLDisplay dpy, EGLSurface surface )
13EGLBoolean eglQuerySurface ( EGLDisplay dpy, EGLSurface surface, EGLint attribute, EGLint *value )
14EGLBoolean eglBindAPI ( EGLenum api )
15EGLenum eglQueryAPI ( void )
16EGLBoolean eglWaitClient ( void )
17EGLBoolean eglReleaseThread ( void )
18EGLSurface eglCreatePbufferFromClientBuffer ( EGLDisplay dpy, EGLenum buftype, EGLClientBuffer buffer, EGLConfig config, const EGLint *attrib_list )
19EGLBoolean eglSurfaceAttrib ( EGLDisplay dpy, EGLSurface surface, EGLint attribute, EGLint value )
20EGLBoolean eglBindTexImage ( EGLDisplay dpy, EGLSurface surface, EGLint buffer )
21EGLBoolean eglReleaseTexImage ( EGLDisplay dpy, EGLSurface surface, EGLint buffer )
22EGLBoolean eglSwapInterval ( EGLDisplay dpy, EGLint interval )
23EGLContext eglCreateContext ( EGLDisplay dpy, EGLConfig config, EGLContext share_context, const EGLint *attrib_list )
24EGLBoolean eglDestroyContext ( EGLDisplay dpy, EGLContext ctx )
25EGLBoolean eglMakeCurrent ( EGLDisplay dpy, EGLSurface draw, EGLSurface read, EGLContext ctx )
26EGLContext eglGetCurrentContext ( void )
27EGLSurface eglGetCurrentSurface ( EGLint readdraw )
28EGLDisplay eglGetCurrentDisplay ( void )
29EGLBoolean eglQueryContext ( EGLDisplay dpy, EGLContext ctx, EGLint attribute, EGLint *value )
30EGLBoolean eglWaitGL ( void )
31EGLBoolean eglWaitNative ( EGLint engine )
32EGLBoolean eglSwapBuffers ( EGLDisplay dpy, EGLSurface surface )
33EGLBoolean eglCopyBuffers ( EGLDisplay dpy, EGLSurface surface, EGLNativePixmapType target )
34