1#
2# Copyright (C) 2015 The Android Open Source Project
3#
4# Licensed under the Apache License, Version 2.0 (the "License");
5# you may not use this file except in compliance with the License.
6# You may obtain a copy of the License at
7#
8#      http://www.apache.org/licenses/LICENSE-2.0
9#
10# Unless required by applicable law or agreed to in writing, software
11# distributed under the License is distributed on an "AS IS" BASIS,
12# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13# See the License for the specific language governing permissions and
14# limitations under the License.
15#
16
17header:
18summary: Graphics Functions and Types
19description:
20 The graphics subsystem of RenderScript was removed at API level 23.
21include:
22 #ifdef __LP64__
23 // TODO We need to fix some of the builds before enabling this error:
24 // #error "RenderScript graphics is deprecated and not supported in 64bit mode."
25 #endif
26
27 // TODO we seem to assume order for the other headers too.
28 #include "rs_object_types.rsh"
29end:
30
31type: rs_blend_src_func
32version: 16 22
33size: 32
34enum:
35value: RS_BLEND_SRC_ZERO = 0
36value: RS_BLEND_SRC_ONE = 1
37value: RS_BLEND_SRC_DST_COLOR = 2
38value: RS_BLEND_SRC_ONE_MINUS_DST_COLOR = 3
39value: RS_BLEND_SRC_SRC_ALPHA = 4
40value: RS_BLEND_SRC_ONE_MINUS_SRC_ALPHA = 5
41value: RS_BLEND_SRC_DST_ALPHA = 6
42value: RS_BLEND_SRC_ONE_MINUS_DST_ALPHA = 7
43value: RS_BLEND_SRC_SRC_ALPHA_SATURATE = 8
44value: RS_BLEND_SRC_INVALID = 100
45deprecated: 22
46summary: Blend source function
47description:
48end:
49
50type: rs_blend_dst_func
51version: 16 22
52size: 32
53enum:
54value: RS_BLEND_DST_ZERO = 0
55value: RS_BLEND_DST_ONE = 1
56value: RS_BLEND_DST_SRC_COLOR = 2
57value: RS_BLEND_DST_ONE_MINUS_SRC_COLOR = 3
58value: RS_BLEND_DST_SRC_ALPHA = 4
59value: RS_BLEND_DST_ONE_MINUS_SRC_ALPHA = 5
60value: RS_BLEND_DST_DST_ALPHA = 6
61value: RS_BLEND_DST_ONE_MINUS_DST_ALPHA = 7
62value: RS_BLEND_DST_INVALID = 100
63deprecated: 22
64summary: Blend destination function
65description:
66end:
67
68type: rs_cull_mode
69version: 16 22
70size: 32
71enum:
72value: RS_CULL_BACK = 0
73value: RS_CULL_FRONT = 1
74value: RS_CULL_NONE = 2
75value: RS_CULL_INVALID = 100
76deprecated: 22
77summary: Culling mode
78description:
79end:
80
81type: rs_depth_func
82version: 16 22
83size: 32
84enum:
85value: RS_DEPTH_FUNC_ALWAYS = 0, "Always drawn"
86value: RS_DEPTH_FUNC_LESS = 1, "Drawn if the incoming depth value is less than that in the depth buffer"
87value: RS_DEPTH_FUNC_LEQUAL = 2, "Drawn if the incoming depth value is less or equal to that in the depth buffer"
88value: RS_DEPTH_FUNC_GREATER = 3, "Drawn if the incoming depth value is greater than that in the depth buffer"
89value: RS_DEPTH_FUNC_GEQUAL = 4, "Drawn if the incoming depth value is greater or equal to that in the depth buffer"
90value: RS_DEPTH_FUNC_EQUAL = 5, "Drawn if the incoming depth value is equal to that in the depth buffer"
91value: RS_DEPTH_FUNC_NOTEQUAL = 6, "Drawn if the incoming depth value is not equal to that in the depth buffer"
92value: RS_DEPTH_FUNC_INVALID = 100, "Invalid depth function"
93deprecated: 22
94summary: Depth function
95description:
96 Specifies conditional drawing depending on the comparison of the incoming
97 depth to that found in the depth buffer.
98end:
99
100type: rs_primitive
101version: 16 22
102size: 32
103enum:
104value: RS_PRIMITIVE_POINT = 0, "Vertex data will be rendered as a series of points"
105value: RS_PRIMITIVE_LINE = 1, "Vertex pairs will be rendered as lines"
106value: RS_PRIMITIVE_LINE_STRIP = 2, "Vertex data will be rendered as a connected line strip"
107value: RS_PRIMITIVE_TRIANGLE = 3, "Vertices will be rendered as individual triangles"
108value: RS_PRIMITIVE_TRIANGLE_STRIP = 4, "Vertices will be rendered as a connected triangle strip defined by the first three vertices with each additional triangle defined by a new vertex"
109value: RS_PRIMITIVE_TRIANGLE_FAN = 5, "Vertices will be rendered as a sequence of triangles that all share first vertex as the origin"
110value: RS_PRIMITIVE_INVALID = 100, "Invalid primitive"
111deprecated: 22
112summary: How to intepret mesh vertex data
113description:
114 Describes the way mesh vertex data is interpreted when rendering
115end:
116
117type: rs_font
118version: 9 22
119size: 32
120rs_object:
121deprecated: 22
122summary: Handle to a Font
123description:
124 Opaque handle to a RenderScript font object.
125 See: android.renderscript.Font
126end:
127
128
129type: rs_mesh
130version: 9 22
131size: 32
132rs_object:
133deprecated: 22
134summary: Handle to a Mesh
135description:
136 Opaque handle to a RenderScript mesh object.
137 See: android.renderscript.Mesh
138end:
139
140type: rs_program_fragment
141version: 9 22
142size: 32
143rs_object:
144deprecated: 22
145summary: Handle to a ProgramFragment
146description:
147 Opaque handle to a RenderScript ProgramFragment object.
148 See: android.renderscript.ProgramFragment
149end:
150
151type: rs_program_vertex
152version: 9 22
153size: 32
154rs_object:
155deprecated: 22
156summary: Handle to a ProgramVertex
157description:
158 Opaque handle to a RenderScript ProgramVertex object.
159 See: android.renderscript.ProgramVertex
160end:
161
162type: rs_program_raster
163version: 9 22
164size: 32
165rs_object:
166deprecated: 22
167summary: Handle to a ProgramRaster
168description:
169 Opaque handle to a RenderScript ProgramRaster object.
170 See: android.renderscript.ProgramRaster
171end:
172
173type: rs_program_store
174version: 9 22
175size: 32
176rs_object:
177deprecated: 22
178summary: Handle to a ProgramStore
179description:
180 Opaque handle to a RenderScript ProgramStore object.
181 See: android.renderscript.ProgramStore
182end:
183
184function: rsClearObject
185version: 9 22
186size: 32
187t: rs_mesh, rs_program_fragment, rs_program_vertex, rs_program_raster, rs_program_store, rs_font
188ret: void
189arg: #1* dst
190test: none
191end:
192
193function: rsIsObject
194version: 9 22
195size: 32
196t: rs_mesh, rs_program_fragment, rs_program_vertex, rs_program_raster, rs_program_store, rs_font
197ret: bool
198arg: #1 v
199test: none
200end:
201
202function: rsSetObject
203version: 9 22
204size: 32
205t: rs_mesh, rs_program_fragment, rs_program_vertex, rs_program_raster, rs_program_store, rs_font
206ret: void
207arg: #1* dst
208arg: #1 src
209test: none
210end:
211
212function: rsgAllocationSyncAll
213version: 9 22
214size: 32
215ret: void
216arg: rs_allocation alloc
217deprecated: 22
218summary: Sync the contents of an allocation
219description:
220 Sync the contents of an allocation.
221
222 If the source is specified, sync from memory space specified by source.
223
224 If the source is not specified, sync from its SCRIPT memory space to its HW
225 memory spaces.
226test: none
227end:
228
229function: rsgAllocationSyncAll
230version: 14 22
231size: 32
232ret: void
233arg: rs_allocation alloc
234arg: rs_allocation_usage_type source
235test: none
236end:
237
238function: rsgBindColorTarget
239version: 14 22
240size: 32
241ret: void
242arg: rs_allocation colorTarget
243arg: uint slot
244deprecated: 22
245summary: Set the color target
246description:
247 Set the color target used for all subsequent rendering calls
248test: none
249end:
250
251function: rsgBindConstant
252version: 9 22
253size: 32
254ret: void
255arg: rs_program_fragment ps, "program fragment object"
256arg: uint slot, "index of the constant buffer on the program"
257arg: rs_allocation c, "constants to bind"
258deprecated: 22
259summary: Bind a constant allocation
260description:
261 Bind a new Allocation object to a ProgramFragment or ProgramVertex.
262 The Allocation must be a valid constant input for the Program.
263test: none
264end:
265
266function: rsgBindConstant
267version: 9 22
268size: 32
269ret: void
270arg: rs_program_vertex pv, "program vertex object"
271arg: uint slot
272arg: rs_allocation c
273test: none
274end:
275
276function: rsgBindDepthTarget
277version: 14 22
278size: 32
279ret: void
280arg: rs_allocation depthTarget
281deprecated: 22
282summary: Set the depth target
283description:
284 Set the depth target used for all subsequent rendering calls
285test: none
286end:
287
288function: rsgBindFont
289version: 9 22
290size: 32
291ret: void
292arg: rs_font font, "object to bind"
293deprecated: 22
294summary: Bind a font object
295description:
296 Binds the font object to be used for all subsequent font rendering calls
297test: none
298end:
299
300function: rsgBindProgramFragment
301version: 9 22
302size: 32
303ret: void
304arg: rs_program_fragment pf
305deprecated: 22
306summary: Bind a ProgramFragment
307description:
308 Bind a new ProgramFragment to the rendering context.
309test: none
310end:
311
312function: rsgBindProgramRaster
313version: 9 22
314size: 32
315ret: void
316arg: rs_program_raster pr
317deprecated: 22
318summary: Bind a ProgramRaster
319description:
320 Bind a new ProgramRaster to the rendering context.
321test: none
322end:
323
324function: rsgBindProgramStore
325version: 9 22
326size: 32
327ret: void
328arg: rs_program_store ps
329deprecated: 22
330summary: Bind a ProgramStore
331description:
332 Bind a new ProgramStore to the rendering context.
333test: none
334end:
335
336function: rsgBindProgramVertex
337version: 9 22
338size: 32
339ret: void
340arg: rs_program_vertex pv
341deprecated: 22
342summary: Bind a ProgramVertex
343description:
344 Bind a new ProgramVertex to the rendering context.
345test: none
346end:
347
348function: rsgBindSampler
349version: 9 22
350size: 32
351ret: void
352arg: rs_program_fragment fragment
353arg: uint slot
354arg: rs_sampler sampler
355deprecated: 22
356summary: Bind a sampler
357description:
358 Bind a new Sampler object to a ProgramFragment.  The sampler will
359 operate on the texture bound at the matching slot.
360test: none
361end:
362
363function: rsgBindTexture
364version: 9 22
365size: 32
366ret: void
367arg: rs_program_fragment v
368arg: uint slot
369arg: rs_allocation alloc
370deprecated: 22
371summary: Bind a texture allocation
372description:
373 Bind a new Allocation object to a ProgramFragment.  The
374 Allocation must be a valid texture for the Program.  The sampling
375 of the texture will be controled by the Sampler bound at the
376 matching slot.
377test: none
378end:
379
380function: rsgClearAllRenderTargets
381version: 14 22
382size: 32
383ret: void
384deprecated: 22
385summary: Clear all color and depth targets
386description:
387 Clear all color and depth targets and resume rendering into
388 the framebuffer
389test: none
390end:
391
392function: rsgClearColor
393version: 9 22
394size: 32
395ret: void
396arg: float r
397arg: float g
398arg: float b
399arg: float a
400deprecated: 22
401summary: Clear the specified color from the surface
402description:
403 Clears the rendering surface to the specified color.
404test: none
405end:
406
407function: rsgClearColorTarget
408version: 14 22
409size: 32
410ret: void
411arg: uint slot
412deprecated: 22
413summary: Clear the color target
414description:
415 Clear the previously set color target
416test: none
417end:
418
419function: rsgClearDepth
420version: 9 22
421size: 32
422ret: void
423arg: float value
424deprecated: 22
425summary: Clear the depth surface
426description:
427 Clears the depth suface to the specified value.
428test: none
429end:
430
431function: rsgClearDepthTarget
432version: 14 22
433size: 32
434ret: void
435deprecated: 22
436summary: Clear the depth target
437description:
438 Clear the previously set depth target
439test: none
440end:
441
442function: rsgDrawMesh
443version: 9 22
444size: 32
445ret: void
446arg: rs_mesh ism, "mesh object to render"
447deprecated: 22
448summary: Draw a mesh
449description:
450 Draw a mesh using the current context state.
451
452 If primitiveIndex is specified, draw part of a mesh using the current context state.
453
454 If start and len are also specified, draw specified index range of part of a mesh using the current context state.
455
456 Otherwise the whole mesh is rendered.
457test: none
458end:
459
460function: rsgDrawMesh
461version: 9 22
462size: 32
463ret: void
464arg: rs_mesh ism
465arg: uint primitiveIndex, "for meshes that contain multiple primitive groups this parameter specifies the index of the group to draw."
466test: none
467end:
468
469function: rsgDrawMesh
470version: 9 22
471size: 32
472ret: void
473arg: rs_mesh ism
474arg: uint primitiveIndex
475arg: uint start, "starting index in the range"
476arg: uint len, "number of indices to draw"
477test: none
478end:
479
480function: rsgDrawQuad
481version: 9 22
482size: 32
483ret: void
484arg: float x1
485arg: float y1
486arg: float z1
487arg: float x2
488arg: float y2
489arg: float z2
490arg: float x3
491arg: float y3
492arg: float z3
493arg: float x4
494arg: float y4
495arg: float z4
496deprecated: 22
497summary: Draw a quad
498description:
499 Low performance utility function for drawing a simple quad.  Not intended for
500 drawing large quantities of geometry.
501test: none
502end:
503
504function: rsgDrawQuadTexCoords
505version: 9 22
506size: 32
507ret: void
508arg: float x1
509arg: float y1
510arg: float z1
511arg: float u1
512arg: float v1
513arg: float x2
514arg: float y2
515arg: float z2
516arg: float u2
517arg: float v2
518arg: float x3
519arg: float y3
520arg: float z3
521arg: float u3
522arg: float v3
523arg: float x4
524arg: float y4
525arg: float z4
526arg: float u4
527arg: float v4
528deprecated: 22
529summary: Draw a textured quad
530description:
531 Low performance utility function for drawing a textured quad.  Not intended
532 for drawing large quantities of geometry.
533test: none
534end:
535
536function: rsgDrawRect
537version: 9 22
538size: 32
539ret: void
540arg: float x1
541arg: float y1
542arg: float x2
543arg: float y2
544arg: float z
545deprecated: 22
546summary: Draw a rectangle
547description:
548 Low performance utility function for drawing a simple rectangle.  Not
549 intended for drawing large quantities of geometry.
550test: none
551end:
552
553function: rsgDrawSpriteScreenspace
554version: 9 22
555size: 32
556ret: void
557arg: float x
558arg: float y
559arg: float z
560arg: float w
561arg: float h
562deprecated: 22
563summary: Draw rectangles in screenspace
564description:
565 Low performance function for drawing rectangles in screenspace.  This
566 function uses the default passthough ProgramVertex.  Any bound ProgramVertex
567 is ignored.  This function has considerable overhead and should not be used
568 for drawing in shipping applications.
569test: none
570end:
571
572function: rsgDrawText
573version: 9 22
574size: 32
575ret: void
576arg: const char* text
577arg: int x
578arg: int y
579deprecated: 22
580summary: Draw a text string
581description:
582 Draws text given a string and location
583test: none
584end:
585
586function: rsgDrawText
587version: 9 22
588size: 32
589ret: void
590arg: rs_allocation alloc
591arg: int x
592arg: int y
593test: none
594end:
595
596function: rsgFinish
597version: 14 22
598size: 32
599ret: uint
600deprecated: 22
601summary: End rendering commands
602description:
603 Force RenderScript to finish all rendering commands
604test: none
605end:
606
607function: rsgFontColor
608version: 9 22
609size: 32
610ret: void
611arg: float r, "red component"
612arg: float g, "green component"
613arg: float b, "blue component"
614arg: float a, "alpha component"
615deprecated: 22
616summary: Set the font color
617description:
618 Sets the font color for all subsequent rendering calls
619test: none
620end:
621
622function: rsgGetHeight
623version: 9 22
624size: 32
625ret: uint
626deprecated: 22
627summary: Get the surface height
628description:
629 Get the height of the current rendering surface.
630test: none
631end:
632
633function: rsgGetWidth
634version: 9 22
635size: 32
636ret: uint
637deprecated: 22
638summary: Get the surface width
639description:
640 Get the width of the current rendering surface.
641test: none
642end:
643
644function: rsgMeasureText
645version: 9 22
646size: 32
647ret: void
648arg: const char* text
649arg: int* left
650arg: int* right
651arg: int* top
652arg: int* bottom
653deprecated: 22
654summary: Get the bounding box for a text string
655description:
656 Returns the bounding box of the text relative to (0, 0)
657 Any of left, right, top, bottom could be NULL
658test: none
659end:
660
661function: rsgMeasureText
662version: 9 22
663size: 32
664ret: void
665arg: rs_allocation alloc
666arg: int* left
667arg: int* right
668arg: int* top
669arg: int* bottom
670test: none
671end:
672
673function: rsgMeshComputeBoundingBox
674version: 9 22
675size: 32
676ret: void
677arg: rs_mesh mesh
678arg: float* minX
679arg: float* minY
680arg: float* min
681arg: float* maxX
682arg: float* maxY
683arg: float* maxZ
684deprecated: 22
685summary: Compute a bounding box
686description:
687 Computes an axis aligned bounding box of a mesh object
688test: none
689end:
690
691function: rsgMeshComputeBoundingBox
692version: 9 22
693size: 32
694ret: void
695arg: rs_mesh mesh
696arg: float3* bBoxMin
697arg: float3* bBoxMax
698inline:
699 float x1, y1, z1, x2, y2, z2;
700 rsgMeshComputeBoundingBox(mesh, &x1, &y1, &z1, &x2, &y2, &z2);
701 bBoxMin->x = x1;
702 bBoxMin->y = y1;
703 bBoxMin->z = z1;
704 bBoxMax->x = x2;
705 bBoxMax->y = y2;
706 bBoxMax->z = z2;
707test: none
708end:
709
710function: rsgMeshGetIndexAllocation
711version: 16 22
712size: 32
713ret: rs_allocation, "allocation containing index data"
714arg: rs_mesh m, "mesh to get data from"
715arg: uint32_t index, "index of the index allocation"
716deprecated: 22
717summary: Return an allocation containing index data
718description:
719 Returns an allocation containing index data or a null
720 allocation if only the primitive is specified
721test: none
722end:
723
724function: rsgMeshGetPrimitive
725version: 16 22
726size: 32
727ret: rs_primitive, "primitive describing how the mesh is rendered"
728arg: rs_mesh m, "mesh to get data from"
729arg: uint32_t index, "index of the primitive"
730deprecated: 22
731summary: Return the primitive
732description:
733 Returns the primitive describing how a part of the mesh is
734 rendered
735test: none
736end:
737
738function: rsgMeshGetPrimitiveCount
739version: 16 22
740size: 32
741ret: uint32_t, "number of primitive groups in the mesh. This would include simple primitives as well as allocations containing index data"
742arg: rs_mesh m, "mesh to get data from"
743deprecated: 22
744summary: Return the number of index sets
745description:
746 Meshes could have multiple index sets, this function returns
747 the number.
748test: none
749end:
750
751function: rsgMeshGetVertexAllocation
752version: 16 22
753size: 32
754ret: rs_allocation, "allocation containing vertex data"
755arg: rs_mesh m, "mesh to get data from"
756arg: uint32_t index, "index of the vertex allocation"
757deprecated: 22
758summary: Return a vertex allocation
759description:
760 Returns an allocation that is part of the mesh and contains
761 vertex data, e.g. positions, normals, texcoords
762test: none
763end:
764
765function: rsgMeshGetVertexAllocationCount
766version: 16 22
767size: 32
768ret: uint32_t, "number of allocations in the mesh that contain vertex data"
769arg: rs_mesh m, "mesh to get data from"
770deprecated: 22
771summary: Return the number of vertex allocations
772description:
773 Returns the number of allocations in the mesh that contain
774 vertex data
775test: none
776end:
777
778function: rsgProgramFragmentConstantColor
779version: 9 22
780size: 32
781ret: void
782arg: rs_program_fragment pf
783arg: float r
784arg: float g
785arg: float b
786arg: float a
787deprecated: 22
788summary: Set the constant color for a fixed function emulation program
789description:
790 Set the constant color for a fixed function emulation program.
791test: none
792end:
793
794function: rsgProgramVertexGetProjectionMatrix
795version: 9 22
796size: 32
797ret: void
798arg: rs_matrix4x4* proj, "matrix to store the current projection matrix into"
799deprecated: 22
800summary: Get the projection matrix for a fixed function vertex program
801description:
802 Get the projection matrix for a currently bound fixed function
803 vertex program. Calling this function with a custom vertex shader
804 would result in an error.
805test: none
806end:
807
808function: rsgProgramVertexLoadModelMatrix
809version: 9 22
810size: 32
811ret: void
812arg: const rs_matrix4x4* model, "model matrix"
813deprecated: 22
814summary: Load the model matrix for a bound fixed function vertex program
815description:
816 Load the model matrix for a currently bound fixed function
817 vertex program. Calling this function with a custom vertex shader
818 would result in an error.
819test: none
820end:
821
822function: rsgProgramVertexLoadProjectionMatrix
823version: 9 22
824size: 32
825ret: void
826arg: const rs_matrix4x4* proj, "projection matrix"
827deprecated: 22
828summary: Load the projection matrix for a bound fixed function vertex program
829description:
830 Load the projection matrix for a currently bound fixed function
831 vertex program. Calling this function with a custom vertex shader
832 would result in an error.
833test: none
834end:
835
836function: rsgProgramVertexLoadTextureMatrix
837version: 9 22
838size: 32
839ret: void
840arg: const rs_matrix4x4* tex, "texture matrix"
841deprecated: 22
842summary:  Load the texture matrix for a bound fixed function vertex program
843description:
844 Load the texture matrix for a currently bound fixed function
845 vertex program. Calling this function with a custom vertex shader
846 would result in an error.
847test: none
848end:
849
850function: rsgProgramRasterGetCullMode
851version: 16 22
852size: 32
853ret: rs_cull_mode
854arg: rs_program_raster pr, "program raster to query"
855deprecated: 22
856summary: Get program raster cull mode
857description:
858 Get program raster cull mode
859test: none
860end:
861
862function: rsgProgramRasterIsPointSpriteEnabled
863version: 16 22
864size: 32
865ret: bool
866arg: rs_program_raster pr, "program raster to query"
867deprecated: 22
868summary: Get program raster point sprite state
869description:
870 Get program raster point sprite state
871test: none
872end:
873
874function: rsgProgramStoreGetBlendDstFunc
875version: 16 22
876size: 32
877ret: rs_blend_dst_func
878arg: rs_program_store ps, "program store to query"
879deprecated: 22
880summary: Get program store blend destination function
881description:
882 Get program store blend destination function
883test: none
884end:
885
886function: rsgProgramStoreGetBlendSrcFunc
887version: 16 22
888size: 32
889ret: rs_blend_src_func
890arg: rs_program_store ps, "program store to query"
891deprecated: 22
892summary: Get program store blend source function
893description:
894 Get program store blend source function
895test: none
896end:
897
898function: rsgProgramStoreGetDepthFunc
899version: 16 22
900size: 32
901ret: rs_depth_func
902arg: rs_program_store ps, "program store to query"
903deprecated: 22
904summary: Get program store depth function
905description:
906 Get program store depth function
907test: none
908end:
909
910function: rsgProgramStoreIsColorMaskAlphaEnabled
911version: 16 22
912size: 32
913ret: bool
914arg: rs_program_store ps, "program store to query"
915deprecated: 22
916summary: Get program store alpha component color mask
917description:
918 Get program store alpha component color mask
919test: none
920end:
921
922function: rsgProgramStoreIsColorMaskBlueEnabled
923version: 16 22
924size: 32
925ret: bool
926arg: rs_program_store ps, "program store to query"
927deprecated: 22
928summary: Get program store blur component color mask
929description:
930 Get program store blur component color mask
931test: none
932end:
933
934function: rsgProgramStoreIsColorMaskGreenEnabled
935version: 16 22
936size: 32
937ret: bool
938arg: rs_program_store ps, "program store to query"
939deprecated: 22
940summary: Get program store green component color mask
941description:
942 Get program store green component color mask
943test: none
944end:
945
946function: rsgProgramStoreIsColorMaskRedEnabled
947version: 16 22
948size: 32
949ret: bool
950arg: rs_program_store ps, "program store to query"
951deprecated: 22
952summary: Get program store red component color mask
953description:
954 Get program store red component color mask
955test: none
956end:
957
958function: rsgProgramStoreIsDepthMaskEnabled
959version: 16 22
960size: 32
961ret: bool
962arg: rs_program_store ps, "program store to query"
963deprecated: 22
964summary: Get program store depth mask
965description:
966 Get program store depth mask
967test: none
968end:
969
970function: rsgProgramStoreIsDitherEnabled
971version: 16 22
972size: 32
973ret: bool
974arg: rs_program_store ps, "program store to query"
975deprecated: 22
976summary: Get program store dither state
977description:
978 Get program store dither state
979test: none
980end:
981