1#
2# Copyright (C) 2015 The Android Open Source Project
3#
4# Licensed under the Apache License, Version 2.0 (the "License");
5# you may not use this file except in compliance with the License.
6# You may obtain a copy of the License at
7#
8#      http://www.apache.org/licenses/LICENSE-2.0
9#
10# Unless required by applicable law or agreed to in writing, software
11# distributed under the License is distributed on an "AS IS" BASIS,
12# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13# See the License for the specific language governing permissions and
14# limitations under the License.
15#
16
17header:
18summary: Input/Output Functions
19description:
20 These functions are used to:<ul>
21 <li>Send information to the Java client, and</li>
22#TODO We need better documentation for:
23 <li>Send the processed allocation or receive the next allocation to process.</li></ul>
24end:
25
26function: rsAllocationIoReceive
27version: 16
28ret: void
29arg: rs_allocation a, "Allocation to work on."
30summary: Receive new content from the queue
31description:
32 Receive a new set of contents from the queue.
33#TODO We need better documentation.
34
35 This function should not be called from inside a kernel, or from any function
36 that may be called directly or indirectly from a kernel. Doing so would cause a
37 runtime error.
38test: none
39end:
40
41function: rsAllocationIoSend
42version: 16
43ret: void
44arg: rs_allocation a, "Allocation to work on."
45summary: Send new content to the queue
46description:
47 Send the contents of the Allocation to the queue.
48#TODO We need better documentation.
49
50 This function should not be called from inside a kernel, or from any function
51 that may be called directly or indirectly from a kernel. Doing so would cause a
52 runtime error.
53test: none
54end:
55
56function: rsSendToClient
57ret: bool
58arg: int cmdID
59summary: Send a message to the client, non-blocking
60description:
61 Sends a message back to the client.  This call does not block.
62 It returns true if the message was sent and false if the
63 message queue is full.
64
65 A message ID is required.  The data payload is optional.
66
67 See <a href='http://developer.android.com/reference/android/renderscript/RenderScript.RSMessageHandler.html'>RenderScript.RSMessageHandler</a>.
68test: none
69end:
70
71function: rsSendToClient
72ret: bool
73arg: int cmdID
74arg: const void* data, "Application specific data."
75arg: uint len, "Length of the data, in bytes."
76test: none
77end:
78
79function: rsSendToClientBlocking
80ret: void
81arg: int cmdID
82summary: Send a message to the client, blocking
83description:
84 Sends a message back to the client.  This function will block
85 until there is room on the message queue for this message.
86 This function may return before the message was delivered and
87 processed by the client.
88
89 A message ID is required.  The data payload is optional.
90
91 See <a href='http://developer.android.com/reference/android/renderscript/RenderScript.RSMessageHandler.html'>RenderScript.RSMessageHandler</a>.
92test: none
93end:
94
95function: rsSendToClientBlocking
96ret: void
97arg: int cmdID
98arg: const void* data, "Application specific data."
99arg: uint len, "Length of the data, in bytes."
100test: none
101end:
102