Lines Matching refs:dimension

61 field: uint32_t xStart, "Starting index in the X dimension."
62 field: uint32_t xEnd, "Ending index (exclusive) in the X dimension."
63 field: uint32_t yStart, "Starting index in the Y dimension."
64 field: uint32_t yEnd, "Ending index (exclusive) in the Y dimension."
65 field: uint32_t zStart, "Starting index in the Z dimension."
66 field: uint32_t zEnd, "Ending index (exclusive) in the Z dimension."
67 field: uint32_t arrayStart, "Starting index in the Array0 dimension."
68 field: uint32_t arrayEnd, "Ending index (exclusive) in the Array0 dimension."
69 field: uint32_t array1Start, "Starting index in the Array1 dimension."
70 field: uint32_t array1End, "Ending index (exclusive) in the Array1 dimension."
71 field: uint32_t array2Start, "Starting index in the Array2 dimension."
72 field: uint32_t array2End, "Ending index (exclusive) in the Array2 dimension."
73 field: uint32_t array3Start, "Starting index in the Array3 dimension."
74 field: uint32_t array3End, "Ending index (exclusive) in the Array3 dimension."
83 over cells 4, 5, 6, and 7 in the X dimension, set xStart to 4 and xEnd to 8.
236 summary: Index in the Array0 dimension for the specified kernel context
238 Returns the index in the Array0 dimension of the cell being processed, as specified
254 This function returns 0 if the Array0 dimension is not present.
262 summary: Index in the Array1 dimension for the specified kernel context
264 Returns the index in the Array1 dimension of the cell being processed, as specified
267 Returns 0 if the Array1 dimension is not present.
275 summary: Index in the Array2 dimension for the specified kernel context
277 Returns the index in the Array2 dimension of the cell being processed,
281 Returns 0 if the Array2 dimension is not present.
289 summary: Index in the Array3 dimension for the specified kernel context
291 Returns the index in the Array3 dimension of the cell being processed, as specified
294 Returns 0 if the Array3 dimension is not present.
302 summary: Size of the Array0 dimension for the specified kernel context
304 Returns the size of the Array0 dimension for the specified kernel context.
307 Returns 0 if the Array0 dimension is not present.
317 summary: Size of the Array1 dimension for the specified kernel context
319 Returns the size of the Array1 dimension for the specified kernel context.
322 Returns 0 if the Array1 dimension is not present.
330 summary: Size of the Array2 dimension for the specified kernel context
332 Returns the size of the Array2 dimension for the specified kernel context.
335 Returns 0 if the Array2 dimension is not present.
343 summary: Size of the Array3 dimension for the specified kernel context
345 Returns the size of the Array3 dimension for the specified kernel context.
348 Returns 0 if the Array3 dimension is not present.
386 summary: Size of the X dimension for the specified kernel context
388 Returns the size of the X dimension for the specified kernel context.
398 To get the dimension of specific allocation, use @rsAllocationGetDimX().
406 summary: Size of the Y dimension for the specified kernel context
408 Returns the size of the X dimension for the specified kernel context.
411 Returns 0 if the Y dimension is not present.
413 To get the dimension of specific allocation, use @rsAllocationGetDimY().
421 summary: Size of the Z dimension for the specified kernel context
423 Returns the size of the Z dimension for the specified kernel context.
426 Returns 0 if the Z dimension is not present.
428 To get the dimension of specific allocation, use @rsAllocationGetDimZ().
441 Returns RS_ALLOCATION_CUBEMAP_FACE_POSITIVE_X if the face dimension is not
450 summary: Index in the Levels of Detail dimension for the specified kernel context
452 Returns the index in the Levels of Detail dimension of the cell being processed,
456 Returns 0 if the Levels of Detail dimension is not present.