Lines Matching refs:kernel

20  The @rsForEach() function can be used to invoke the root kernel of a script.
23 an executing kernel, like dimensions and current indices. These functions take
38 This type is used to suggest how the invoked kernel should iterate over the cells of the
41 This specification can help the caching behavior of the running kernel, e.g. the cache
48 summary: Handle to a kernel invocation context
50 The kernel context contains common characteristics of the allocations being iterated
54 You can access the kernel context by adding a special parameter named "context" of type
55 rs_kernel_context to your kernel function. See @rsGetDimX() and @rsGetArray0() for examples.
89 summary: Handle to a kernel function
91 An opaque type for a function that is defined with the kernel attribute. A value
92 of this type can be used in a @rsForEach call to launch a kernel.
103 summary: Launches a kernel
105 Runs the kernel over zero or more input allocations. They are passed after the
106 @rs_kernel argument. If the specified kernel returns a value, an output allocation
111 the work has completed for all cells of the input allocations. If the kernel
115 Up to API level 23, the kernel is implicitly specified as the kernel named
117 Starting in API level 24, an arbitrary kernel function can be used,
118 as specified by the kernel argument. The script argument is removed.
119 The kernel must be defined in the current script. In addition, more than one
123 float __attribute__((kernel)) square(float a) {<br/>
182 arg: rs_kernel kernel, "Function designator to a function that is defined with the kernel attribute."
193 arg: rs_kernel kernel, "Function designator to a function that is defined with the kernel attribute."
196 summary: Launches a kernel with options
198 Launches kernel in a way similar to @rsForEach. However, instead of processing
201 by options, no input or output allocation is required for a kernel launch using
203 and return value expected by the kernel function. The output allocation is
204 present if and only if the kernel has a non-void return value.
223 arg: int hasOutput, "Indicates whether the kernel generates output"
226 summary: (Internal API) Launch a kernel in the current Script (with the slot number)
228 Internal API to launch a kernel.
236 summary: Index in the Array0 dimension for the specified kernel context
239 by the supplied kernel context.
241 The kernel context contains common characteristics of the allocations being iterated
244 You can access the kernel context by adding a special parameter named "context" of
245 type rs_kernel_context to your kernel function. E.g.<br/>
249 &nbsp;&nbsp;// to the other dimensions, extract them from the kernel context:<br/>
262 summary: Index in the Array1 dimension for the specified kernel context
265 by the supplied kernel context. See @rsGetArray0() for an explanation of the context.
275 summary: Index in the Array2 dimension for the specified kernel context
278 as specified by the supplied kernel context. See @rsGetArray0() for an explanation
289 summary: Index in the Array3 dimension for the specified kernel context
292 by the supplied kernel context. See @rsGetArray0() for an explanation of the context.
302 summary: Size of the Array0 dimension for the specified kernel context
304 Returns the size of the Array0 dimension for the specified kernel context.
317 summary: Size of the Array1 dimension for the specified kernel context
319 Returns the size of the Array1 dimension for the specified kernel context.
330 summary: Size of the Array2 dimension for the specified kernel context
332 Returns the size of the Array2 dimension for the specified kernel context.
343 summary: Size of the Array3 dimension for the specified kernel context
345 Returns the size of the Array3 dimension for the specified kernel context.
356 summary: Presence of more than one face for the specified kernel context
358 If the kernel is iterating over a cubemap, this function returns true if there's more
370 summary: Number of levels of detail for the specified kernel context
372 Returns the number of levels of detail for the specified kernel context. This is useful
386 summary: Size of the X dimension for the specified kernel context
388 Returns the size of the X dimension for the specified kernel context.
390 The kernel context contains common characteristics of the allocations being iterated
394 type rs_kernel_context to your kernel function. E.g.<br/>
406 summary: Size of the Y dimension for the specified kernel context
408 Returns the size of the X dimension for the specified kernel context.
421 summary: Size of the Z dimension for the specified kernel context
423 Returns the size of the Z dimension for the specified kernel context.
436 summary: Coordinate of the Face for the specified kernel context
439 supplied kernel context. See @rsGetArray0() for an explanation of the context.
450 summary: Index in the Levels of Detail dimension for the specified kernel context
453 as specified by the supplied kernel context. See @rsGetArray0() for an explanation of