1%define version 2.2.5
2%define release 1
3
4Summary: Expat is an XML 1.0 parser written in C.
5Name: expat
6Version: %{version}
7Release: %{release}
8License: MIT/X
9Group: Utilities/parsers
10URL: http://www.libexpat.org/
11Source: https://downloads.sourceforge.net/project/expat/expat/%{version}/expat-%{version}.tar.bz2
12BuildRoot: /var/tmp/%{name}-buildroot
13
14%description
15Expat is an XML 1.0 parser written in C by James Clark.  It aims to be
16fully conforming. It is not a validating XML parser.
17
18%prep
19%setup
20
21%build
22./configure
23make lib xmlwf
24
25%install
26rm -rf $RPM_BUILD_ROOT
27mkdir -p $RPM_BUILD_ROOT/usr/bin
28mkdir -p $RPM_BUILD_ROOT/usr/lib
29mkdir -p $RPM_BUILD_ROOT/usr/include
30make install DESTDIR=$RPM_BUILD_ROOT prefix=/usr
31install -D xmlwf/xmlwf $RPM_BUILD_ROOT/usr/bin/xmlwf
32
33%files
34%doc COPYING README.md doc/reference.html doc/style.css doc/*.png
35/usr/bin/xmlwf
36/usr/lib
37/usr/include/expat.h
38/usr/include/expat_config.h
39/usr/include/expat_external.h
40/usr/share/doc/expat/AUTHORS
41/usr/share/doc/expat/changelog
42/usr/share/man/man1/xmlwf.1.gz
43
44%changelog
45* Tue Oct 31 2017 Sebastian Pipping <sebastian@pipping.org>
46[Release 2.2.5-1]
47- Update for the 2.2.5 release.
48
49* Sat Aug 19 2017 Sebastian Pipping <sebastian@pipping.org>
50[Release 2.2.4-1]
51- Update for the 2.2.4 release.
52
53* Wed Aug 2 2017 Sebastian Pipping <sebastian@pipping.org>
54[Release 2.2.3-1]
55- Update for the 2.2.3 release.
56
57* Wed Jul 12 2017 Sebastian Pipping <sebastian@pipping.org>
58[Release 2.2.2-1]
59- Update for the 2.2.2 release.
60
61* Sat Jun 17 2017 Sebastian Pipping <sebastian@pipping.org>
62[Release 2.2.1-1]
63- Update for the 2.2.1 release.
64
65* Tue Jun 21 2016 Sebastian Pipping <sebastian@pipping.org>
66[Release 2.2.0-1]
67- Update for the 2.2.0 release.
68
69* Wed Mar 2 2016 Sebastian Pipping <sebastian@pipping.org>
70[Release 2.1.1-1]
71- Update for the 2.1.1 release.
72
73* Sat Mar 3 2012 Karl Waclawek <karl@waclawek.net>
74[Release 2.1.0-1]
75- Update for the 2.1.0 release.
76
77* Sun Nov 26 2006 Karl Waclawek <karl@waclawek.net>
78[Release 2.0.1-1]
79- Update for the 2.0.1 release.
80
81* Fri Jul 16 2004 Fred L. Drake, Jr. <fdrake@acm.org>
82[Release 1.95.8-1]
83- Update for the 1.95.8 release.
84- Add the expat_external.h header to the installed files.
85
86* Tue Oct 21 2003 Fred L. Drake, Jr. <fdrake@acm.org>
87- Update list of documentation files; we missed a .png file in the
88  previous release.
89
90* Mon Oct 20 2003 Fred L. Drake, Jr. <fdrake@acm.org>
91[Release 1.95.7-1]
92- Updated for the 1.95.7 release.
93
94* Sat Jan 25 2003 Fred L. Drake, Jr. <fdrake@acm.org>
95[Release 1.95.6-1]
96- Updated for the 1.95.6 release.
97
98* Wed Sep  4 2002 Fred L. Drake, Jr. <fdrake@acm.org>
99[Release 1.95.5-1]
100- Updated for the 1.95.5 release.
101- Updated URL for Expat home page to point to www.libexpat.org.
102- Added "Valid XHTML 1.0" icon to the installed documentation.
103
104* Sat Jun 29 2002 Fred L. Drake, Jr. <fdrake@acm.org>
105[Release 1.95.4-1]
106- Updated for the 1.95.4 release.
107
108* Fri May 17 2002 Fred L. Drake, Jr. <fdrake@acm.org>
109[Release 1.95.3-1]
110- Updated for the 1.95.3 release.
111- Added xmlwf man page to the list of files.
112
113* Wed Jul 25 2001 Fred L. Drake, Jr. <fdrake@acm.org>
114[Release 1.95.2-1]
115- Updated for the 1.95.2 release.
116
117* Sun Feb 18 2001 Sean Reifschneider <jafo-rpms@tummy.com>
118[Release 1.95.1-1tummy]
119- Updated to 1.95.1 release.
120- Removed the "/usr/include/expat" directory for headers, as it now uses
121  "expat.h" instead of "xmlparser.h".
122
123* Thu Jan 25 2001 Sean Reifschneider <jafo-rpms@tummy.com>
124[Release 1.1-3tummy]
125- Moved xmlparse.h into "/usr/include/expat" directory to prevent conflict
126  with w3c-libwww-devel package.
127
128* Wed Sep  6 2000 Sean Reifschneider <jafo-rpms@tummy.com>
129- Modified to install into /usr.
130- Modified to use RPM_BUILD_ROOT instead of writing directly to install
131  location.
132