History log of /frameworks/base/graphics/java/android/graphics/BitmapRegionDecoder.java
Revision Date Author Comments (<<< Hide modified files) (Show modified files >>>)
3bbcbcd5f908cef5c0bf7078c3352185f1ff6ddc 15-May-2012 Owen Lin <owenlin@google.com> Release the constraint on the requested version.

Allowing to request a region that partially outsides the image.
bug: 5884845

Change-Id: I32344930ab9e2a7f22a706914babb165843e8de7
/frameworks/base/graphics/java/android/graphics/BitmapRegionDecoder.java
96d3b5e38301f5d4eff01de8730b6021eb167af9 12-Jan-2011 Wei-Ta Chen <weita@google.com> Correct the API comments.

BitmapRegionDecoder supports PNG as well.

Change-Id: I5f1b95c20c3ae87738f9814cfc16d6a4c5af2bf5
/frameworks/base/graphics/java/android/graphics/BitmapRegionDecoder.java
6b849e2123be98eb2a1a25b8abf0b13a279ce952 07-Sep-2010 Wei-Ta Chen <weita@google.com> Unhide BitmapRegionDecoder.

1. Rename LargeBitmap to BitmapRegionDecoder
2. Move the instantiations of BitmapRegionDecoder out of BitmapFactory.
3. Remove the use of MemoryFile in BitmapRegionDecoder, since MemoryFile's API had been modified in master. Otherwise, the change will break the master build.
4. Move AssetStreamAdaptor, AutoFDSeek and nullObjectReturn to Utils.h because BitmapFactory.cpp and BitmapRegionDecoder.cpp both need to use these utility functions.

Most of the modifications, except for (2) and (3), were reviewed in https://android-git.corp.google.com/g/#change,64716 .
However, that change broke the master build due to (3) and was reverted eventually.
So, instead of withdrawing this change and waiting for that change to be checked in again, I merge the two changes into one.

Change-Id: I2202c0fbbbd6d6676bbd9637e690023ea4099c40
/frameworks/base/graphics/java/android/graphics/BitmapRegionDecoder.java
340ce75b446f6a6afc12b0582be3fc34ac3a5364 08-Sep-2010 Wei-Ta Chen <weita@google.com> Revert "Rename LargeBitmap to BitmapRegionDecoder for having a better API."

This reverts commit 50ba3d2c09a9131f3578d271adf2bc8258ca1742.
/frameworks/base/graphics/java/android/graphics/BitmapRegionDecoder.java
50ba3d2c09a9131f3578d271adf2bc8258ca1742 07-Sep-2010 Wei-Ta Chen <weita@google.com> Rename LargeBitmap to BitmapRegionDecoder for having a better API.

Move AssetStreamAdaptor, AutoFDSeek and nullObjectReturn to Utils.h because
BitmapFactory.cpp and BitmapRegionDecoder.cpp both need to use these utility functions.

Change-Id: I3e60c7fe4abd0289e1384e69a08fd20fe6fb0e10
/frameworks/base/graphics/java/android/graphics/BitmapRegionDecoder.java