History log of /libcore/include/ScopedUtfChars.h
Revision Date Author Comments
a5d02941bc6dd7621b935d270a3522bfcb8bc98b 02-Jun-2010 Elliott Hughes <enh@google.com> Fix sim-eng build with missing #include.

Change-Id: I77d9841f7112235096c54ac70479ad09f2b0559d
753dcd862b31e85766225590d90ba0b9f481176f 02-Jun-2010 Elliott Hughes <enh@google.com> Refactor some of the OSNetworkSystem stuff to more appropriate homes.

Also rewrite PlainDatagramSocketImpl.peek in terms of existing primitives
rather than requiring its own. I still don't see how it can get called, but
at least now it doesn't require its own native code.

Bug: 2686833

Change-Id: I0453add66dab4c7095ee2a3f51a49efbd1205598
05960876dff6a5b686821eed8f7ae7cef5af4f50 27-May-2010 Elliott Hughes <enh@google.com> Enhance ScopedUtfChars to include the null check most callers were missing.

Also switch most non-users over to ScopedUtfChars.

Also ensure all users check that ScopedUtfChars was successful in getting the
chars.

Also rewrite ObjectInputStream and ObjectOutputStream without duplication.

Change-Id: I929d00fe3ff50b303cba4a2cf2269355e9fef5f9
0808cae1a2616ba9c708c7cc4489723b4060178e 24-Apr-2010 Elliott Hughes <enh@google.com> Dead code/cruft removal in the collation code.

I've also renamed ScopedUtfChars::data to ScopedUtfChars::c_str, by analogy
with std::string (since this method has always been more like c_str than data).

This also fixes a few leaks on error paths.

The old code used to go all the way into native code to return a constant hash
code of 1, so I've removed all that and switched to the idiomatic bogo hash
code (with the idiomatic comment).

Change-Id: I25da8c422155860b5ab348786d369c6c7598135c
bcf7c66e617ad0c33bb320184bb2401def517342 26-Mar-2010 Elliott Hughes <enh@google.com> Start cleaning up the Charset implementation.

This was going to be https://issues.apache.org/jira/browse/HARMONY-6461,
but I couldn't resist cleaning up some of the surrounding code, and ended
up cleaning up some of our native code too. In the course of the afternoon
I spent on this, I lost my conviction that the upstream change makes
sense, so I reverted that, leaving this change just pure cleanup.

(Note that the cleanup work is incomplete. This is an improvement, but
there's plenty left to do. I just don't want to get too distracted until
all the Java 6 changes are done.)

Change-Id: I56841db5f6c038bbf7942e83a148dca546519269