1// RUN: %clang_cc1 -fcxx-exceptions -fexceptions -verify -std=c++11 %s
2struct A { };
3struct B { };
4struct C { };
5
6// Destructor
7struct X0 {
8  virtual ~X0() throw(A); // expected-note{{overridden virtual function is here}}
9};
10struct X1 {
11  virtual ~X1() throw(B); // expected-note{{overridden virtual function is here}}
12};
13struct X2 : public X0, public X1 { }; // expected-error 2{{exception specification of overriding function is more lax than base version}}
14
15// Copy-assignment operator.
16struct CA0 {
17  CA0 &operator=(const CA0&) throw(A);
18};
19struct CA1 {
20  CA1 &operator=(const CA1&) throw(B);
21};
22struct CA2 : CA0, CA1 { };
23
24void test_CA() {
25  CA2 &(CA2::*captr1)(const CA2&) throw(A, B) = &CA2::operator=;
26  CA2 &(CA2::*captr2)(const CA2&) throw(A, B, C) = &CA2::operator=;
27  CA2 &(CA2::*captr3)(const CA2&) throw(A) = &CA2::operator=; // expected-error{{target exception specification is not superset of source}}
28  CA2 &(CA2::*captr4)(const CA2&) throw(B) = &CA2::operator=; // expected-error{{target exception specification is not superset of source}}
29}
30
31// In-class member initializers.
32struct IC0 {
33  int inClassInit = 0;
34};
35struct IC1 {
36  int inClassInit = (throw B(), 0);
37};
38// FIXME: the exception specification on the default constructor is wrong:
39// we cannot currently compute the set of thrown types.
40static_assert(noexcept(IC0()), "IC0() does not throw");
41static_assert(!noexcept(IC1()), "IC1() throws");
42
43namespace PR13381 {
44  struct NoThrowMove {
45    NoThrowMove(const NoThrowMove &);
46    NoThrowMove(NoThrowMove &&) noexcept;
47    NoThrowMove &operator=(const NoThrowMove &);
48    NoThrowMove &operator=(NoThrowMove &&) noexcept;
49  };
50  struct NoThrowMoveOnly {
51    NoThrowMoveOnly(NoThrowMoveOnly &&) noexcept;
52    NoThrowMoveOnly &operator=(NoThrowMoveOnly &&) noexcept;
53  };
54  struct X {
55    const NoThrowMove a;
56    NoThrowMoveOnly b;
57
58    static X val();
59    static X &ref();
60  };
61  // These both perform a move, but that copy might throw, because it calls
62  // NoThrowMove's copy constructor (because PR13381::a is const).
63  static_assert(!noexcept(X(X::val())), "");
64  static_assert(!noexcept(X::ref() = X::val()), "");
65}
66