1// RUN: %clang_cc1 -std=c++11 -fsyntax-only -verify %s
2// expected-no-diagnostics
3
4// FIXME: More bullets to go!
5
6template<typename T, typename U>
7struct has_nondeduced_pack_test {
8  static const bool value = false;
9};
10
11template<typename R, typename FirstType, typename ...Types>
12struct has_nondeduced_pack_test<R(FirstType, Types..., int),
13                                R(FirstType, Types...)> {
14  static const bool value = true;
15};
16
17// - A function parameter pack that does not occur at the end of the
18//   parameter-declaration-clause.
19int check_nondeduced_pack_test0[
20                   has_nondeduced_pack_test<int(float, double, int),
21                                            int(float, double)>::value? 1 : -1];
22
23
24