History log of /frameworks/base/media/java/android/service/media/MediaBrowserService.java
Revision Date Author Comments (<<< Hide modified files) (Show modified files >>>)
92e565f71526141cb38f864dcb4eeb54d2cbf869 04-Sep-2014 RoboErik <epastern@google.com> rename SERVICE_ACTION to SERVICE_INTERFACE

For API consistency this intent is suppose to be named SERVICE_INTERFACE.

bug:17390782
Change-Id: I4c3b1d8476dd6c939792f73615e92d7bfa6d5758
/frameworks/base/media/java/android/service/media/MediaBrowserService.java
c692d05951561e1d9fde952cc5389ec167bdb7bb 30-Aug-2014 RoboErik <epastern@google.com> Update MediaBrowser to use String ids instead of Uris

Since we converted MediaDescription over to using a String media id
for identifying everything we should also use Strings in the browser
service to make it clear that it should re-use that field.

bug:17333205
Change-Id: I5fd5762bdad05068f5b1aa36074306b43432e686
/frameworks/base/media/java/android/service/media/MediaBrowserService.java
3625bf72cb8bcf3c7f8f8cd8d708d7206824cc62 28-Aug-2014 RoboErik <epastern@google.com> Update to MediaBrowser APIs per council feedback

Does all the updates in the bug except the loadIcon/loadBitmap
methods, which are removed per feedback from Sharkey.

bug:17205016
Change-Id: Ie84d4d25a59c6985ce16972c26c8d1e5c02ff5c9
/frameworks/base/media/java/android/service/media/MediaBrowserService.java