History log of /frameworks/wilhelm/tests/sandbox/xaplay.c
Revision Date Author Comments (<<< Hide modified files) (Show modified files >>>)
01f8573bc2a850536b02855d483dfe130c050a2f 12-Mar-2013 Ashok Bhat <ashok.bhat@arm.com> AArch64: Minor changes related to 64-bit platform

Changes include
[x] Use %zu for size_t
[x] Use PRId64 to print 64-bit integer value
[x] Use uintptr_t for integer variable used to store address.

Change-Id: I69926cce76b0d645f1abccd584444197a5e40318
Signed-off-by: Marcus Oakland <marcus.oakland@arm.com>
Signed-off-by: Ashok Bhat <ashok.bhat@arm.com>
/frameworks/wilhelm/tests/sandbox/xaplay.c
04a960c641a5885784f84382c0dabd6d34f70226 07-Nov-2011 Glenn Kasten <gkasten@google.com> Merge "xaplay test additions"
b17edb96ba759cd1197bf13cd13e279ee144da60 30-Aug-2011 Glenn Kasten <gkasten@google.com> xaplay test additions

Allow playing a subset of input file.
Add format change test.
Call gComposerClient->dispose before exit.
Remove dead code related to re-initializing the engine.
Add position, seek, loop tests.
Force callback failures with -c option.
Don't enqueue EOS more than once.
Add STOPPED at end of xaplay.
Add temporary set play state to paused.
Added discontinuity test.
More stream information queries and printfs.
Shorter marker to make it easier to hit when looping.
Add explanation of command line options.

Change-Id: I5b425a52f9afc2c8f9083badb6de0773f711c6d9
/frameworks/wilhelm/tests/sandbox/xaplay.c
c3b82a293ed06001ba6d50f111608160c6065ef2 18-Sep-2011 Glenn Kasten <gkasten@google.com> Final revisions for NDK API level 14

Rename ANDROID_MIME_MP2TS to XA_ANDROID_MIME_MP2TS and
ANDROID_MIME_AACADTS to SL_ANDROID_MIME_AACADTS and make public.
ANDROID_MIME_AACADTS_ANDROID_FRAMEWORK remains private.

Change-Id: Ie2cda273b6adb2db453aad188b28e64147f9e6b0
/frameworks/wilhelm/tests/sandbox/xaplay.c
60ca9f9ef02f6e486c3338cb811f603dd7825c05 29-Aug-2011 Glenn Kasten <gkasten@google.com> Rename Android buffer queue GUID for future sink

This change will make it easier to have Android buffer queue as a sink in
the future. For backwards source code compatibility with beta developers,
retain the old name temporarily. As soon as they have switched to the
new name, we will remove the old name.

Details:
- rename XA_IID_ANDROIDBUFFERQUEUE to XA_IID_ANDROIDBUFFERQUEUESOURCE
- rename SL_IID_ANDROIDBUFFERQUEUE to SL_IID_ANDROIDBUFFERQUEUESOURCE
- rename MPH_ANDROIDBUFFERQUEUE to MPH_ANDROIDBUFFERQUEUESOURCE
- did not rename the data locators and interface struct,
as they can be shared across both source and sink
- did not rename the member field mAndroidBufferQueue in
CAudioPlayer / CMediaPlayer as that would be a huge change;
can do that later if necessary
- the SINK definition will be added later when needed

Change-Id: I36dc01050efb99d4d7802b2ca2b870f4d978ee21
/frameworks/wilhelm/tests/sandbox/xaplay.c
75290ff394698c53f35a21612c03b8ddd21fecf9 22-Aug-2011 Glenn Kasten <gkasten@google.com> xaplay command-line mediaplayer for MPEG-2 TS ABQ

Change-Id: Id5ea3f478f45d4fa4b86772593ae831d9eade952
/frameworks/wilhelm/tests/sandbox/xaplay.c