1#
2# Copyright (C) 2015 The Android Open Source Project
3#
4# Licensed under the Apache License, Version 2.0 (the "License");
5# you may not use this file except in compliance with the License.
6# You may obtain a copy of the License at
7#
8#      http://www.apache.org/licenses/LICENSE-2.0
9#
10# Unless required by applicable law or agreed to in writing, software
11# distributed under the License is distributed on an "AS IS" BASIS,
12# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13# See the License for the specific language governing permissions and
14# limitations under the License.
15#
16
17header:
18summary: Input/Output Functions
19description:
20 These functions are used to:<ul>
21 <li>Send information to the Java client, and</li>
22#TODO We need better documentation for:
23 <li>Send the processed allocation or receive the next allocation to process.</li></ul>
24end:
25
26function: rsAllocationIoReceive
27version: 16
28ret: void
29arg: rs_allocation a, "Allocation to work on."
30summary: Receive new content from the queue
31description:
32 Receive a new set of contents from the queue.
33#TODO We need better documentation.
34test: none
35end:
36
37function: rsAllocationIoSend
38version: 16
39ret: void
40arg: rs_allocation a, "Allocation to work on."
41summary: Send new content to the queue
42description:
43 Send the contents of the Allocation to the queue.
44#TODO We need better documentation.
45test: none
46end:
47
48function: rsSendToClient
49ret: bool
50arg: int cmdID
51summary: Send a message to the client, non-blocking
52description:
53 Sends a message back to the client.  This call does not block.
54 It returns true if the message was sent and false if the
55 message queue is full.
56
57 A message ID is required.  The data payload is optional.
58
59 See <a href='http://developer.android.com/reference/android/renderscript/RenderScript.RSMessageHandler.html'>RenderScript.RSMessageHandler</a>.
60test: none
61end:
62
63function: rsSendToClient
64ret: bool
65arg: int cmdID
66arg: const void* data, "Application specific data."
67arg: uint len, "Length of the data, in bytes."
68test: none
69end:
70
71function: rsSendToClientBlocking
72ret: void
73arg: int cmdID
74summary: Send a message to the client, blocking
75description:
76 Sends a message back to the client.  This function will block
77 until there is room on the message queue for this message.
78 This function may return before the message was delivered and
79 processed by the client.
80
81 A message ID is required.  The data payload is optional.
82
83 See <a href='http://developer.android.com/reference/android/renderscript/RenderScript.RSMessageHandler.html'>RenderScript.RSMessageHandler</a>.
84test: none
85end:
86
87function: rsSendToClientBlocking
88ret: void
89arg: int cmdID
90arg: const void* data, "Application specific data."
91arg: uint len, "Length of the data, in bytes."
92test: none
93end:
94