1#
2# Copyright (C) 2015 The Android Open Source Project
3#
4# Licensed under the Apache License, Version 2.0 (the "License");
5# you may not use this file except in compliance with the License.
6# You may obtain a copy of the License at
7#
8#      http://www.apache.org/licenses/LICENSE-2.0
9#
10# Unless required by applicable law or agreed to in writing, software
11# distributed under the License is distributed on an "AS IS" BASIS,
12# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13# See the License for the specific language governing permissions and
14# limitations under the License.
15#
16
17header:
18summary: Overview
19description:
20 RenderScript is a high-performance runtime that provides compute operations at the native level.
21 RenderScript code is compiled on devices at runtime to allow platform-independence as well.
22
23 This reference documentation describes the RenderScript runtime APIs, which you can utilize
24 to write RenderScript code in C99. The RenderScript compute header files are automatically
25 included for you.
26
27 To use RenderScript, you need to utilize the RenderScript runtime APIs documented here as well
28 as the Android framework APIs for RenderScript.  For documentation on the Android framework
29 APIs, see the <a target="_parent" href="http://developer.android.com/reference/android/renderscript/package-summary.html">android.renderscript</a> package reference.
30
31 For more information on how to develop with RenderScript and how the runtime and Android
32 framework APIs interact, see the <a target="_parent" href="http://developer.android.com/guide/topics/renderscript/index.html">RenderScript developer guide</a> and the <a target="_parent" href="http://developer.android.com/resources/samples/RenderScript/index.html">RenderScript samples</a>.
33include:
34 #define RS_KERNEL __attribute__((kernel))
35
36 #include "stdbool.h"
37
38 #include "rs_value_types.rsh"
39 #include "rs_object_types.rsh"
40
41 #include "rs_allocation_create.rsh"
42 #include "rs_allocation_data.rsh"
43 #include "rs_atomic.rsh"
44 #include "rs_convert.rsh"
45 #include "rs_debug.rsh"
46 #include "rs_for_each.rsh"
47 #include "rs_io.rsh"
48 #include "rs_math.rsh"
49 #include "rs_matrix.rsh"
50 #include "rs_object_info.rsh"
51 #include "rs_quaternion.rsh"
52 #include "rs_time.rsh"
53 #include "rs_vector_math.rsh"
54end:
55