History log of /frameworks/rs/driver/rsdProgramStore.cpp
Revision Date Author Comments (<<< Hide modified files) (Show modified files >>>)
e939ce7e3b609ee53d73c2b48c5ff8f03b4579a3 16-Nov-2016 Chih-Hung Hsieh <chh@google.com> Fix google-build-using-namespace warnings in driver.

* Replace "using namespace ..." statements with
using declarations of the required names.
* Put extern "C" functions inside a namespace to save
a lot of using declarations. Their linkage names are not
changed but can access names in the namespace easily.

Bug: 32670901
Test: build with WITH_TIDY=1
Change-Id: I7a2d45ecab47bc9064701fd288fe31f47b28fcc9
/frameworks/rs/driver/rsdProgramStore.cpp
44bef6fba6244292b751387f3d6c31cca96c28ad 12-Aug-2014 Chris Wailes <chriswailes@google.com> Replace NULL macros with nullptr literals.

Change-Id: I918c40879aa547438f77e7d1a95fa2aa33bec398
/frameworks/rs/driver/rsdProgramStore.cpp
03f1910431433f3a35f1445aa0bba2b00417f0cc 10-Jan-2012 Steve Block <steveblock@google.com> resolved conflicts for merge of 08289f55 to graphics-dev

Change-Id: I2c95cd461e364cbeae7ffbaea7ad5c87713d7df7
af12ac6a08651464f8d823add667c706f993b587 06-Jan-2012 Steve Block <steveblock@google.com> Rename (IF_)LOGE(_IF) to (IF_)ALOGE(_IF) DO NOT MERGE

See https://android-git.corp.google.com/g/#/c/157220

Bug: 5449033
Change-Id: Ic9c19d30693bd56755f55906127cd6bd7126096c
/frameworks/rs/driver/rsdProgramStore.cpp
c0a65425f8eb3573b1abd2a48292ca953c0a8590 05-Jan-2012 Alex Sakhartchouk <alexst@google.com> Cleanup based on comments.

Change-Id: I2d261b3cd240b890001dcc7d2a849cfdc34328bf
/frameworks/rs/driver/rsdProgramStore.cpp
2382aba4a55c6ae74789c478eead8fbd96593321 14-Sep-2011 Jason Sams <rjsams@android.com> Add RS watchdog.

Change-Id: I4c912beb84fa8a37ada0088049f7776132e994b6
/frameworks/rs/driver/rsdProgramStore.cpp
8feea4e0dec48ea03bd6d32706d058b86dddc5ba 18-Mar-2011 Jason Sams <rjsams@android.com> Seperate GL from RS program store.

Change-Id: I0eae9c0699845af8e8611b065e70738cc9f2b15c
/frameworks/rs/driver/rsdProgramStore.cpp