History log of /drivers/net/wireless/wl12xx/io.c
Revision Date Author Comments (<<< Hide modified files) (Show modified files >>>)
0f4e31222a2c0b93f25a87effd2033cb78c7a79c 07-Oct-2011 Luciano Coelho <coelho@ti.com> wl12xx: move debugging definitions to a separate file

Separate the debugging macros and other definitions to a new debug.h
file. This is be needed because the sdio and spi modules don't need
to depend on the wl12xx module anymore, but still need to include
wl12xx.h. Currently they do depend on it, because of the debugging
global that wl12xx exports. A future patch will remove this
dependency.

Signed-off-by: Luciano Coelho <coelho@ti.com>
/drivers/net/wireless/wl12xx/io.c
a390e85cfe91c346ff4745bcd45ad0a7e7101aa2 06-Oct-2011 Felipe Balbi <balbi@ti.com> wl12xx: move common init code from bus modules to main

Move all common parts from sdio.c and spi.c to main.c, since they now
can be handled as part of the platform driver.

Signed-off-by: Felipe Balbi <balbi@ti.com>
[forward-ported, cleaned-up and rephrased commit message]
[added a bunch of fixes and a new pdata element]
[moved some new code into main.c as well]
Signed-off-by: Luciano Coelho <coelho@ti.com>
/drivers/net/wireless/wl12xx/io.c
a011130265e999056fe0678a064d828c2fd40174 18-May-2011 Eliad Peller <eliad@wizery.com> wl12xx: remove unused crc7 references

crc7 is used only in wl12xx_spi.

Remove redundant crc7.h includes, and update Kconfig to select CRC7
only if WL12XX_SPI is being selected.

Signed-off-by: Eliad Peller <eliad@wizery.com>
Signed-off-by: Luciano Coelho <coelho@ti.com>
/drivers/net/wireless/wl12xx/io.c
77d7d7a36d270fee4591c1c99c83c2da1f399d44 13-May-2011 Felipe Balbi <balbi@ti.com> net: wl12xx: care for optional operations

->init and ->reset are optional - at least
sdio.c doesn't implement them - so allow those
pointers to be NULL.

Signed-off-by: Felipe Balbi <balbi@ti.com>
Signed-off-by: Luciano Coelho <coelho@ti.com>
/drivers/net/wireless/wl12xx/io.c
0da13da767cd568c1fe2a7b5b936e86e521b5ae7 31-Mar-2011 Ido Yariv <ido@wizery.com> wl12xx: Clean up the block size alignment code

Simplify and clean up the block size alignment code:
1. Set the block size according to the padding field type, as it cannot
exceed the maximum value this field can hold.
2. Move the alignment code into a function instead of duplicating it in
multiple places.
3. In the current implementation, the block_size member can be
misleading because a zero value actually means that there's no need to
align. Declare a block size alignment quirk instead.

Signed-off-by: Ido Yariv <ido@wizery.com>
Signed-off-by: Luciano Coelho <coelho@ti.com>
/drivers/net/wireless/wl12xx/io.c
48a61477bdc04896bd96d259388a0c42a7019943 06-Mar-2011 Shahar Levi <shahar_levi@ti.com> wl12xx: 1281/1283 support - Add acx commands

New acx command that sets: Rx fifo enable reduced bus transactions
in RX path. Tx bus transactions padding to SDIO block size that
improve preference in Tx and essential for working with SDIO HS (48Mhz).
The max SDIO block size is 256 when working with Tx bus transactions
padding to SDIO block.

Add new ops to SDIO & SPI that handles the win size change in case of
transactions padding (relevant only for SDIO).

[Fix endianess issues; simplify sdio-specific block_size handling;
minor changes in comments; use "aligned_len" in one calculation
instead of "pad" to avoid confusion -- Luca]

Signed-off-by: Shahar Levi <shahar_levi@ti.com>
Reviewed-by: Luciano Coelho <coelho@ti.com>
Signed-off-by: Luciano Coelho <coelho@ti.com>
/drivers/net/wireless/wl12xx/io.c
870c367cf829466f315de785ac613dd94eff5c50 29-Nov-2010 Roger Quadros <roger.quadros@nokia.com> wl1271: Add wl1271_load_firmware() and export some functions

For the SDIO testing module we need to load the firmware but not
boot it. wl1271_load_firmware() is meant to do just the firmware loading part.

We also export some functions so they are usable in the testing module.

Signed-off-by: Roger Quadros <roger.quadros@nokia.com>
Signed-off-by: Luciano Coelho <luciano.coelho@nokia.com>
/drivers/net/wireless/wl12xx/io.c
00d201001bd4e8a46e3d03c970abcb72256c368b 08-Nov-2010 Shahar Levi <shahar_levi@ti.com> wl1271: Change wl12xx Files Names

All files name prefix removed due to the fact that wl12xx driver supports
wl1271 and wl1273.
Also the definition in Kconfig and header files changed respectively.

Signed-off-by: Shahar Levi <shahar_levi@ti.com>
Signed-off-by: Luciano Coelho <luciano.coelho@nokia.com>
/drivers/net/wireless/wl12xx/io.c